Website forms error

I have just joined Cloudflare and am a couple of days in and today my website enquiry forms won’t submit and are showing an error - is this likely to be connected with CF and does CF actually protect all the online enquiry forms on my website?

Whats the URL?

https://www.decorativecollective.com and https://www.thehoarde.com

You menioned one site. So it is two? What exactly does not work?

If you copy and past this it will take you to one of my own items (not my dealers) and you can test it by clicking on the Enquire About this Item tab.
Thanks

Sorry here’s link https://www.decorativecollective.com/dealers/antiques-and-decorative/p/superb-wrought-iron-console-table-aad041

Enquiring seems to work.

image

My website sells items for various dealers around the UK and Europe. I have two accounts one for each site (but managed under just the one login).

Clients fill in enquiry forms when they want to contact the dealer either on a product page or from the Directory page. When you fill these in, an error is coming up when you try to submit them. It just says ‘an error has occurred please try later’. I am askng my web company to look into this as it was working OK last night as far as I’m aware though it has been very slow in terms of enquiries since I joined Cloudflare and linked it to my sites. I am trying to find out form CF if anything your end might be affecting my forms and if you actually protect all forms on my sites.

It’s not working for me still nor my colleague in the UK.

I’d dig into the developer console and debug why it may fail. On my end it appears to work, at least it didnt show an error and displayed the confirmation message.

If you have Rocket Loader on Cloudflare enabled you could try to disable it. But apart from that possibility it should not be Cloudflare related.

Thank you Sandro, but I’m still getting the same error on both Hoarde Vintage (the url for that is https://www.thehoarde.com) and again please try items for Antiques and Decorative on that site too. Link to all my items is https://www.thehoarde.com/products#!/q=__dealer=antiques-decorative

I don’t have Rocket Loader enabled (not sure what that is) only Argo.

Same on Hoarde

image

Try it in different browsers.

which browser are you using Sandro, I’m using Firefox.

I’ve just tried it in Safari and it’s not working on there either

Firefox as well. Maybe try clearing your cache. I am guessing at this point I am afraid.

It’s not that, I’ve just tried it in Chrome too, so that’s 3 browsers it’s not working in. And it’s not just me, no one so far apart from you (and I presume your in the States) can use the forms successfully? I’ve never had this before, so it must be to do with CF. It was working fine initially, so what can have changed? This is very serious for me as without the forms working, my sites are useless

Just tried it in Chrome and it worked too. I somewhat doubt it is Cloudflare related but you simply need to debug this at this point.

This topic was automatically closed after 31 days. New replies are no longer allowed.