Website down after moving to cloudflare

Help! I recently signed up to cloudflare as my current domain provider was retiring their dnp service. I am not trained in tech so find this changeover difficult.
My website is hosted on squarespace and I have gotten to the point where i have put the dns records in on cloudflare and changed the nameservers but the website is still down. Can’t get an answer from either the domain name provider or squarespace.
where am i going wrong?

Welcome to the Cloudflare Community. :logodrop:

Can you share the domain name so that Community members can offer assistance?

leahbeggs.com

1 Like

Are you encountering too many redirects like I am when I try to to visit the site?

Be aure that your Cloudflare Encryption mode is set to Full (strict).

If you encounter errors after switching to Full (strict), please post here so we can assist further.

1 Like

Ok, i just changed that now. How long should it take to take effect?

1 Like

It already has. :smiley:

1 Like

Thank you, it is still saying too many redirects. What else can I do?

1 Like

You might try in incognito mode, as it is loading correctly for me.

I am a little concerned that @sjr’s test site is still showing a redirect from www to www when it doesn’t manifest in my own testing using curl from the command line or a web browser.

https://cf.sjr.org.uk/tools/check?eafe970f5fb0476cb33d2d82fe74e3bd#connection-worker-https

1 Like

Thank you!
Yep when i link to other pages on my site it’s fine. it’s the home page is the problem. which still needs to be fixed.
Thank you for the other info above re the sjr test site. as a tech luddite it doesn’t mean much to me i’m afraid!
Maybe the host at squarespace might have an answer?? Or do you think its a dns record issue?

1 Like

That link to the test site was mainly for the benefit of its author or anyone else that happens upon this topic. I also included it because it still showed a redirect that I am unable to reproduce.

It seems unlikely since your homepage loads correctly for me. Squarespace recommends against proxying any hostnames that point to their service. You can try setting setting your hostnames to :grey: DNS Only.

1 Like

which record is considered the host name? ie; Cname , A ??
Thanks

1 Like

They both are, but only the A record will contain an IP. A CNAME points to another name, which is then queried for an IP. If you are using a placeholder IP to trigger a redirect rule in your Cloudflare account, be sure to keep that name :orange: proxied.

I’m still seeing “too many redirects” from the server and at home (Safari/Firefox/Chrome/curl). I have no idea how your browser isn’t doing it though, quite odd. The circular redirect is on the Squarespace origin…

curl -I https://www.leahbeggs.com/ --resolve www.leahbeggs.com:443:198.185.xxx.xxx
HTTP/2 301
age: 27160
date: Tue, 11 Jun 2024 10:17:44 GMT
location: https://www.leahbeggs.com/
server: Squarespace
set-cookie: crumb=Bf+XR8Hf/czsMDZhMDU1MTMwY2Q0MmU3MWM4ODZhYjQ5YWIyMjg3;Secure;Path=/
x-contextid: I4iJyhgw/UwGYu5dO
content-length: 0
1 Like

so would the best thing to do now is it talk to squarespace?

% curl -I https://www.leahbeggs.com/ 
HTTP/2 200 
date: Tue, 11 Jun 2024 19:29:36 GMT
content-type: text/html;charset=utf-8
age: 13187
expires: Thu, 01 Jan 1970 00:00:00 GMT
set-cookie: crumb=BfpWN5Q2L6RDZGY2ODRlMjcxMGQ1MjE5NDFiZjlkOWVlMGEwODY3;Secure;Path=/
strict-transport-security: max-age=0
vary: Accept-Encoding
x-content-type-options: nosniff
x-contextid: 0zDcDU05/Q3i5747b
cf-cache-status: DYNAMIC
report-to: {"endpoints":[{"url":"https:\/\/a.nel.cloudflare.com\/report\/v4?s=68jCh%2B2t%2FViwTPw8xjLEJFVd%2BdfuWM6csPj8jo693wzlwT66rXBRzXsKBkaD8qxGiDemOgF8SfUE4l72949%2BF1IZy4OarYDsQObSei%2BEdnBuQYmtrv0OZ%2B8t%2BmcuvBUfmpMUSvrVV6i4PsoP3lgE5Q%3D%3D"}],"group":"cf-nel","max_age":604800}
nel: {"success_fraction":0,"report_to":"cf-nel","max_age":604800}
server: cloudflare
cf-ray: 892402c94efcec3c-SEA
alt-svc: h3=":443"; ma=86400

That would be reasonable next step. I would consider pausing Cloudflare before you do, just to prevent them from getting distracted.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.