Website domain name

I have a Fine Art American website and I cannot get my website to show up after following instructions to add the domain name. Any help is appreciated.
Thank you

Welcome to the Cloudflare community support forum, Diane :clap:

I checked your website, and I see the error message: ERR_TOO_MANY_REDIRECTS (“This page isn’t working: redirected you too many times.”).

This error is usually caused by an incorrect SSL/TLS encryption mode selection. Please check SSL/TLS in your Cloudflare dashboard, and ensure yours is set to Full (strict) and let’s test to see if that fixes the problem.

Standing by.

1 Like

Hi, thank you for getting back to me. I changed it but it says the same thing. redirects to on Cloudflare - check your page rules and redirect rules. redirects back to on your origin.

Hence the circular redirection. One of those redirects needs to be removed depending on which one you want as your actual public URL.

curl -I
HTTP/2 301
date: Fri, 10 Nov 2023 16:47:23 GMT
cache-control: max-age=3600
expires: Fri, 10 Nov 2023 17:47:23 GMT
report-to: {"endpoints":[{"url":"https:\/\/\/report\/v3?s=xOM2HiqMMso%2Bzkx%2BXDYbs1N05m79fuIlE3E6CfqLeE65TGx9fOZ2yU1rWd6BgEjpm8tp1QqMN6y%2FYiQIY6jLuRJPIgjYOWzpGnlAkUufa5eh3SpU1jDqqBxp%2BmggBeqm6v4tehrLyqmnWpRxUA2xNglyAOfHPA%3D%3D"}],"group":"cf-nel","max_age":604800}
nel: {"success_fraction":0,"report_to":"cf-nel","max_age":604800}
server: cloudflare
cf-ray: 823fc6eb4b52dcdf-LHR
alt-svc: h3=":443"; ma=86400
curl -I
HTTP/2 301
date: Fri, 10 Nov 2023 16:47:17 GMT
content-type: text/html; charset=UTF-8
x-frame-options: SAMEORIGIN
set-cookie: PHPSESSID=c80739acaef90e2af4c4fc3f0305c869; path=/; samesite=none; secure; HttpOnly
set-cookie: SERVERID=s6; path=/; Secure; SameSite=None
expires: Thu, 19 Nov 1981 08:52:00 GMT
cache-control: no-store, no-cache, must-revalidate, post-check=0, pre-check=0
pragma: no-cache
strict-transport-security: max-age=31536000; includeSubDomains; preload;
cf-cache-status: DYNAMIC
report-to: {"endpoints":[{"url":"https:\/\/\/report\/v3?s=VhwRfe6Tqrm1%2B2iSI%2FJ2eZKPz1AeTzNjS0yw5JP3EJChRj103hdgmWoYMnqHdus24UnQdBpT%2FBoP2NVROKsofftCDcaJAjSoAPbxKmsn%2FgsoRu62Pbv5kfIeEzBjZA1VPOzldDik6zVnjN4rOWCfzGGmiDkbi8aZ6Lk%3D"}],"group":"cf-nel","max_age":604800}
nel: {"success_fraction":0,"report_to":"cf-nel","max_age":604800}
server: cloudflare
cf-ray: 823fc6c36a22768f-LHR
alt-svc: h3=":443"; ma=86400
1 Like

Set TLS/SSL to Full (strict) to fix ERR_TOO_MANY_REDIRECTS

Thank you but this is way over my head. I have no idea what you are talking about.

You type into your browser.
Cloudflare passes that request to whoever is hosting your website.
The code there tells your browser to go to
Your browser requests but Cloudflare says to go to
…and then your hosting sends back to and so on until the browser has tried 10 times and then says “too many redirects

Talk to whoever runs your website and ask them to remove the redirect there, or you need to remove the redirect that is set in your Cloudflare account.


Thank you, I tried it but it didn’t work. Any other suggestions?

I have my website with Fine Art America. I have an email to them but have not heard back from them. I was hoping for an easy fix with Cloudflare but I guess not. Any other ideas are greatly appreciated. I had google crawl my site. Could that be a problem? Attached DNS seems to be another site hosted with the same host (is it also your site?) so using that for the CNAME seems a bit strange, but does answer for your site at the moment. Its redirects conflict with those on as noted.

The safest thing to do is to change the CNAME content from to - the way the hosts are set up this will have the effect of redirecting to but should stop the looping. I assume the content is the same.

Try that first, if it doesn’t work we can do it the other way round.

Thanks but it didn’t work. attached my instructions from Fine Art America.
Thank you so much for your time :slight_smile:

Your settings were as they asked. You’ll need to go back to them and tell them what’s happening as it’s a problem at their end.

Point them at this post…

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.