Website doesn't load propery through proxy but perfect if it goes by DNS

Hi, from this last days we are suffering a weird behaviour in our website www.classonlive.com.
Suddenly if we browse to our home, sometimes some resources which should be served through cloudflare remains in pending status so the website doesn’t load os load very slow until we refresh again . This behavior increases if we clean browser cache. During first visit is slow, then normal, then slow again or even doesn’t load.

If we change from proxy to only DNS, the website loads fast always.

I don’t understand what is happening. I have returned to proxy config, and i have turn off cache and purge all files but the problem persists. I dont know if maybe the WAF which I have in my plan is the responsible for this o any other functionality.

I need my website goes thorugh proxy in order to use the WAF configurantion, Cache, etc
so, have anyone suffered this problem during the last 3-4 days and has a solution?

Thanks in advance

Best regards

I see NS_BINDING_ABORTED for some resources out of your domain.

As I can see, cache is working for static files as it is supposed to.

Currently, at my end it loads fast 7.33MB in 1.27s.

Do you have some Page Rules or what kind of cache option enabled? Cache Everything, Cache Standard …?

Also, you are using Polish and Mirage as far as I can see, which helps a lot.
What about Rocket Loader?

Do you have some custom Firewall rules, do you use Managed rules also?

What kind of Security Options have you got enabled at Cloudflare dashboard for your domain?

Hi,
I have the Cache configured as Standard
I test with Rocket but I saw some warnings in browser console similar to
"The resource https://www.classonlive.com/js_common/external/global/restricted.js was preloaded using link preload but not used within a few seconds from the window's load event. Please make sure it has an appropriate as value and it is preloaded intentionally." and the resources were not loaded so i switch off Rocket.

We have some Firewall Rules but regarding to forbid traffic from specific countries. Nothing special. But the Waf has several options enable and also Managed Rules (It always was with these options enabled)

I see other issue regarding your fonts - which costed me 1.5 seconds at the first open of your Website:

downloadable font: kern: Too large subtable (font-family: "open sans" style:normal weight:400 stretch:100 src index:0) source: https://d28dhcwclph1gf.cloudfront.net/css_common/propios/fonts/Open_Sans/OpenSans-Regular.ttf

downloadable font: Table discarded (font-family: "open sans" style:normal weight:400 stretch:100 src index:0) source: https://d28dhcwclph1gf.cloudfront.net/css_common/propios/fonts/Open_Sans/OpenSans-Regular.ttf

downloadable font: kern: Too large subtable (font-family: "open sans" style:normal weight:700 stretch:100 src index:0) source: https://d28dhcwclph1gf.cloudfront.net/css_common/propios/fonts/Open_Sans/OpenSans-Bold.ttf

downloadable font: Table discarded (font-family: "open sans" style:normal weight:700 stretch:100 src index:0) source: https://d28dhcwclph1gf.cloudfront.net/css_common/propios/fonts/Open_Sans/OpenSans-Bold.ttf

Uncaught (in promise) DOMException: The play method is not allowed by the user agent or the platform in the current context, possibly because the user denied permission.

downloadable font: kern: Too large subtable (font-family: "open sans" style:normal weight:600 stretch:100 src index:0) source: https://d28dhcwclph1gf.cloudfront.net/css_common/propios/fonts/Open_Sans/OpenSans-SemiBold.ttf

downloadable font: Table discarded (font-family: "open sans" style:normal weight:600 stretch:100 src index:0) source: https://d28dhcwclph1gf.cloudfront.net/css_common/propios/fonts/Open_Sans/OpenSans-SemiBold.ttf

Possible solution for this:

Or even better, firstly download the needed fonts.

Moreover, have something like this in a .css file:
Example for FontAwesome Icons:

.fa, html{-webkit-font-smoothing:antialiased;text-rendering:optimizelegibility}

@font-face{
  font-family:FontAwesome;
  font-display:fallback;
  src:
      local('FontAwesome'),
      local('FontAwesome Regular'),
      url(css/fonts/fontawesome-webfont.woff2) format('woff2'),
      url(css/fonts/fontawesome-webfont.woff) format('woff'),
      url(css/fonts/fontawesome-webfont.ttf) format('truetype'),
      url(css/fonts/fontawesome-webfont.eot?#iefix) format('embedded-opentype'),
      url(css/fonts/fontawesome-webfont.svg) format('svg');
      font-weight:400;
      font-style:normal;
}
/* When calling this font somewhere, use like */
.myclass{font-family:FontAwesome;}

And use the next tool to convert your font file format to others (the best possible way to all of them and link to them in the CSS) woff, woff2, ttf, eot, otf, svg:

Make sure when calling your CSS file in <head>...</head> section of your Webpage like:

<link href="mycss.css" type="text/css" rel="stylesheet" media="all ... />

To also call the considered font like woff2 with preload and crossorigin="anonymous" attribute :

<link rel="preload" href="myfont.woff2" as="font" crossorigin="anonymous">

That way, woff2 would be loaded and it’s lightweight for Web browser to render, load up and display.

Give it a try and write back to us with some feedback information :wink:

Make sure all the needed fonts are at your origin too.

Due to this cite:

Does firewall rules also block the resources your Website requests from your CDN Cloudfront.net?

Is your Cloudflront configured correctly to work with Cloudflare?:

I don’t use Cloudfront with custom domain, so Cloudflare and Cloudfront serve both different resources.
It is not possible the Cloudflare Firewall blocks Cloudfront requests.
When I see the Chrome console, pending resources to be downloaded are always those which have to be served by cloudflare not by cloudfront. and as aI said before is something regarding the proxy, because if i change to only DNS and resources are served directly from origin and cloudfront everything is working.

URLS like https://d28dhcwclph1gf.cloudfront.net/css_common/propios/fonts/Open_Sans/OpenSans-SemiBold.ttf are not loaded by cloudflare, that in my opinion is not the problem.

I have made a change in DNS so maybe something could help seeing differences.

https://www.classonlive.com goes through cloudflare proxy and has the described problems.
Subdomain https://floresserbyantoniajover.classonlive.com/ goes through by only DNS and doesn’t present the loading problems.

Thnaks in advance

I have found this topic Blank page after turning on CDN and HTTP proxy - #19 by hesham011117 and it seems that turning off several options it works better.

1 Like

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.