Website does not show latest changes, despite clearing cache

Hi,
I’m using Cloudflare for a while now, but I recently changed some articles on my website.
I noticed that my articles are not updated despite clearing my Cache.
My latest article is also not showing, which I published May 4th…

Can anybody tell me what the issue is and if this is a Cloudflare problem.

So basically:
When I’m logged in, I see all the changes I made.

When I’m logged out, I don’t see these changes.

I’m using WP Rocket & Cloudflare, purged Cache multiple times for both.

Thanks

May I ask have you followed below article to correctly setup the WP Rocket and Cloudflare?:

Just for the sake of good order, assuming your server IP address ends in 167, your server certificate has expired more than a month ago and you have an insecure encryption mode on Cloudflare.

1 Like

Yes, I pretty much did everything as recommended in these articles/the video.

  • I contacted my hosting provider to change for me the name servers (You need to contact the support in order to change the name servers)
  • I integrated Cloudlfare via WP Rocket as shown in the video
  • All the settings are pretty much as recommended

I use Clouflare for a couple months now. This year I started writing more freuqently again and I also rewrote some of my articles. I noticed before, that sometimes it took a few days, for the changes to take place, despite clearing the cache.
Now I noticed, that my latest article takes way too long to appear and the changes I made a few days ago, are also not visible when I’m logged out.

Is there a way to diagnose the problem? I haven’t paused Clouflare yet.

Can you explain what you mean exactly?

You’re probably not using Full (Strict) mode for SSL/TLS. That’s not secure.

1 Like

I selected the recommended Full option, but not strict.

Should I change to strict?

Does this have anything to do with my problem?

Ok,
I turned the SSL/TLS Recommender on and it recommended to change the settings to strict.

My SSL setting is now strict.

Thank you for the advice

Does your server IP end in 167?

I’m not sure where to check (sorry I’m a tech noob), but when I go to the DNS Tab, the only visible Server IP ends with .167.

Why?

P.S.: I think I found the problem. It looks like Ezoic changed some things on my website, without letting me know. I cleared Ezoics cache and the changes appear now.

In that case I’d recommend to double check the encryption mode as you still shouldn’t be on Full Strict as you’d otherwise get a 526 error because of the expired certificate. You should contact your host to have that fixed.

Where do you see that my certificate has expired?
I just checked and my SSL certificate (Let’s encrypt) is supposed to be still active

Can you please explain your posts a little bit?
I’m a noob and don’t know how and where to check these things.
When I check my SSL certificate, it says it is active and valid unless you mean something else.

I’d recommend to pause Cloudflare for now, make sure it loads fine on HTTPS without Cloudflare, and only then unpause Cloudflare. You’ll probably have to clarify this with your host.

And as far as WP Rocket is concerned, @fritexvz has already provided feedback.

my caching problem seems to be solved, after clearing Ezoics cache.

I’ll ask a friend regarding the certificate issue.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.