Website crashed


#1

Greetings and HELP!!!
I’m stumbling around your site looking for support because my website crashed, but generates an error message that names Cloudflare as the culprit. Since I work long days, I don’t want to jump through hoops for support. But I enjoy multiple page 1 rankings for my local stump grinding business and I rely on those listings to support my family.
I will apreciate any feedback that moves me closer to a solution starting with: How do I login and get to Cloudflare plugin when my WP login page displays the same Cloudflare Error message that’s on my Homepage???


Welcome! Say hello!
#2

Hello,

Could you let us know the exact issue with a screenshot? We would be glad to help you asap.

Thanks


#3

If you click on the URL, you will see the Cloudflare error message that appears instead of my website on my homepage and my WP login page. But I will copy/paste here and provide the URL again. https://stumpgrinding1.com

Fatal error: Uncaught exception ‘RuntimeException’ with message ‘Unable to check Ipv6. Check that PHP was not compiled with option “disable-ipv6”.’ in /home/stumpg5/public_html/wp-content/plugins/cloudflare/vendor/cloudflare/cf-ip-rewrite/src/CloudFlare/IpUtils.php:114 Stack trace: #0 /home/stumpg5/public_html/wp-content/plugins/cloudflare/vendor/cloudflare/cf-ip-rewrite/src/CloudFlare/IpUtils.php(30): CloudFlare\IpUtils::checkIp6(‘2600:3c03::f03c…’, ‘2400:cb00::/32’) #1 /home/stumpg5/public_html/wp-content/plugins/cloudflare/vendor/cloudflare/cf-ip-rewrite/src/CloudFlare/IpRewrite.php(77): CloudFlare\IpUtils::checkIp(‘2600:3c03::f03c…’, ‘2400:cb00::/32’) #2 /home/stumpg5/public_html/wp-content/plugins/cloudflare/vendor/cloudflare/cf-ip-rewrite/src/CloudFlare/IpRewrite.php(55): CloudFlare\IpRewrite->isCloudFlareIP() #3 /home/stumpg5/public_html/wp-content/plugins/cloudflare/vendor/cloudflare/cf-ip-rewrite/src/CloudFlare/IpRewrite.php(122): CloudFlare\IpRewrite->isCloudFlare() #4 /home/stumpg5/public_html/wp-content/pl in /home/stumpg5/public_html/wp-content/plugins/cloudflare/vendor/cloudflare/cf-ip-rewrite/src/CloudFlare/IpUtils.php on line 114


#4

Did this only start happening after you installed the Cloudflare plugin? If so, based on the error, I would investigate which version of php you have installed because it seems to be barking about IPv6. What kind of server environment is this? Shared hosting with cPanel or something else?


#5

@robert

Hi.
I am unable to access your website. It always says

Though, I tried to access over VPN. And, yes I can see that you are getting some error.

  • Can you try deactivating other all plugins, especially WordFence, and check again. Hope there is no conflict, and you are using updated PHP version.

#6

This is what I see and what tech support at Siteground.com sees:

Fatal error: Uncaught exception ‘RuntimeException’ with message ‘Unable to check Ipv6. Check that PHP was not compiled with option “disable-ipv6”.’ in /home/stumpg5/public_html/wp-content/plugins/cloudflare/vendor/cloudflare/cf-ip-rewrite/src/CloudFlare/IpUtils.php:114 Stack trace: #0 /home/stumpg5/public_html/wp-content/plugins/cloudflare/vendor/cloudflare/cf-ip-rewrite/src/CloudFlare/IpUtils.php(30): CloudFlare\IpUtils::checkIp6(‘2600:3c03::f03c…’, ‘2400:cb00::/32’) #1 /home/stumpg5/public_html/wp-content/plugins/cloudflare/vendor/cloudflare/cf-ip-rewrite/src/CloudFlare/IpRewrite.php(77): CloudFlare\IpUtils::checkIp(‘2600:3c03::f03c…’, ‘2400:cb00::/32’) #2 /home/stumpg5/public_html/wp-content/plugins/cloudflare/vendor/cloudflare/cf-ip-rewrite/src/CloudFlare/IpRewrite.php(55): CloudFlare\IpRewrite->isCloudFlareIP() #3 /home/stumpg5/public_html/wp-content/plugins/cloudflare/vendor/cloudflare/cf-ip-rewrite/src/CloudFlare/IpRewrite.php(122): CloudFlare\IpRewrite->isCloudFlare() #4 /home/stumpg5/public_html/wp-content/pl in /home/stumpg5/public_html/wp-content/plugins/cloudflare/vendor/cloudflare/cf-ip-rewrite/src/CloudFlare/IpUtils.php on line 114


#7

His plugin was poorly coded and gives an error message :confused:
Fatal error: Uncaught exception 'RuntimeException' with message 'Unable to check Ipv6. Check that PHP was not compiled with option "disable-ipv6".' in /home/stumpg5/public_html/wp-content/plugins/cloudflare/vendor/cloudflare/cf-ip-rewrite/src/CloudFlare/IpUtils.php:114 Stack trace: #0 /home/stumpg5/public_html/wp-content/plugins/cloudflare/vendor/cloudflare/cf-ip-rewrite/src/CloudFlare/IpUtils.php(30): CloudFlare\IpUtils::checkIp6('2600:3c03::f03c...', '2400:cb00::/32') #1 /home/stumpg5/public_html/wp-content/plugins/cloudflare/vendor/cloudflare/cf-ip-rewrite/src/CloudFlare/IpRewrite.php(77): CloudFlare\IpUtils::checkIp('2600:3c03::f03c...', '2400:cb00::/32') #2 /home/stumpg5/public_html/wp-content/plugins/cloudflare/vendor/cloudflare/cf-ip-rewrite/src/CloudFlare/IpRewrite.php(55): CloudFlare\IpRewrite->isCloudFlareIP() #3 /home/stumpg5/public_html/wp-content/plugins/cloudflare/vendor/cloudflare/cf-ip-rewrite/src/CloudFlare/IpRewrite.php(122): CloudFlare\IpRewrite->isCloudFlare() #4 /home/stumpg5/public_html/wp-content/pl in /home/stumpg5/public_html/wp-content/plugins/cloudflare/vendor/cloudflare/cf-ip-rewrite/src/CloudFlare/IpUtils.php on line 114


#8

@robert your site seems to be working as of this post :smiley: What did you do to solve the problem?


#9

Since the Cloudflare fatal error message also blocked my access to /wp-admin, I went to Cpanel and accessed the folder containing my plugins and renamed it to effectively turn off all my plugins. Then I was able to login to WP Dashboard. Returned to Cpanel to restore the original name of my plugins folder. Back to WP dashboard to manually turn on all plugins except for Cloudflare. Siteground still insists this is a Cloudflare issue. Cloudflare Support insists that my host’s php is old and cruddy, so won’t handle Ipv6. My site has been running Cloudflare while being hosted at Siteground without incident for nearly a year until the recent WP update to version 4.8. Sorry if hard to read…I am NOT tech-savvy.


#10

seems to be Cloudflare official plugin https://github.com/cloudflare/Cloudflare-WordPress/tree/master/vendor/cloudflare/cf-ip-rewrite

actual line https://github.com/cloudflare/Cloudflare-WordPress/blob/master/vendor/cloudflare/cf-ip-rewrite/src/CloudFlare/IpUtils.php#L114

    public static function checkIp6($requestIp, $ip)
    {
        if (!((extension_loaded('sockets') && defined('AF_INET6')) || @inet_pton('::1'))) {
            throw new \RuntimeException('Unable to check Ipv6. Check that PHP was not compiled with option "disable-ipv6".');
        }

if you have SSH access type commands

php -i | grep v6
php --ri sockets

should report something like

php --ri sockets

sockets

Sockets Support => enabled
php -i | grep v6
IPv6 Support => enabled
IPv6 => Yes

you can also find out php configure options via command

php-config --configure-options

example

php-config --configure-options
--enable-fpm --enable-opcache --enable-intl --enable-pcntl --with-mcrypt --with-snmp --with-mhash --with-zlib --with-gettext --enable-exif --enable-zip --with-bz2 --enable-soap --enable-sockets --enable-sysvmsg --enable-sysvsem --enable-sysvshm --enable-shmop --with-pear --enable-mbstring --with-openssl --with-mysql=mysqlnd --with-libdir=lib64 --with-mysqli=mysqlnd --with-mysql-sock=/var/lib/mysql/mysql.sock --with-curl --with-gd --with-xmlrpc --enable-bcmath --enable-calendar --enable-ftp --enable-gd-native-ttf --with-freetype-dir=/usr --with-jpeg-dir=/usr --with-png-dir=/usr --with-xpm-dir=/usr --with-vpx-dir=/usr --with-t1lib=/usr --enable-pdo --with-pdo-sqlite --with-pdo-mysql=mysqlnd --enable-inline-optimization --with-imap --with-imap-ssl --with-kerberos --with-readline --with-libedit --with-gmp --with-pspell --with-tidy --with-enchant --with-fpm-user=nginx --with-fpm-group=nginx --disable-fileinfo --with-ldap --with-ldap-sasl --with-config-file-scan-dir=/etc/centminmod/php.d --with-xsl CC=/usr/bin/gcc CFLAGS=-O2 -m64 -march=core-avx2 -pipe -gsplit-dwarf CXX=/usr/bin/g++ CXXFLAGS=-O2 -m64 -march=core-avx2 -pipe -gsplit-dwarf

#11

Just because something was published by Cloudflare doesn’t make the code any less crappy.


#12

true :slight_smile:

or could be a php bug https://bugs.php.net/bug.php?id=70252

on my PHP 5.6.30 install

php -r 'echo (int) defined('AF_INET6');'  
0

with

php --ri sockets

sockets

Sockets Support => enabled
php -i | grep v6
IPv6 Support => enabled
IPv6 => Yes
ping6 -c4 google.com
PING google.com(qn-in-x71.1e100.net (2607:f8b0:400d:c00::71)) 56 data bytes
64 bytes from qn-in-x71.1e100.net (2607:f8b0:400d:c00::71): icmp_seq=1 ttl=54 time=9.13 ms
64 bytes from qn-in-x71.1e100.net (2607:f8b0:400d:c00::71): icmp_seq=2 ttl=54 time=9.06 ms
64 bytes from qn-in-x71.1e100.net (2607:f8b0:400d:c00::71): icmp_seq=3 ttl=54 time=9.23 ms
64 bytes from qn-in-x71.1e100.net (2607:f8b0:400d:c00::71): icmp_seq=4 ttl=54 time=9.08 ms

--- google.com ping statistics ---
4 packets transmitted, 4 received, 0% packet loss, time 3003ms
rtt min/avg/max/mdev = 9.063/9.129/9.238/0.095 ms

#13

That Cloudflare didn’t rewrite that code to avoid :angry:


#15

My other Website Hindi Shayari is Working fine on first attempts of Setting up with cloudflare. But when i trying to setting up with True love Shayari with cloudflare it is Showing Too many redirects error. I tried this 3-4 tes but i get same issue every time. And my site goes down for many hours when i try this and this affects my rankings very badly on serp… so i again changes the Nameservers to hosting default Nameservers.
How can i solve this problem ??
Ssl and hosting is from Namecheap.


#16

This usually happens when your SSL settings cause a conflict.

For example, if you have Cloudflare SSL set to Flexible, Cloudflare will connect to your server using HTTP.

But if your server redirects HTTP requests to HTTPS, this tells Cloudflare to try again with HTTPS…but Cloudflare only connects to your server with HTTP. And this causes a redirect loop.

Read this to make sure you have correct SSL settings: