Website caches weird to where I can't navigate

Website: https://www.digitalnomadsage.com

I am using WP Fast Cache for my site because it was recommended by my theme. The problem is that once Cloudflare “Caches” my site… I am no longer able to navigate via the links below.

For example: All Digital Nomading Featured Make Money Online More (In grey)
image

If I purge the cache in Cloudflare, the navigation works just fine. But if I let Cloudflare cache my site…it just hangs and acts like it’s trying to process or navigate but gets stuck in a loop with the animation icon moving in a circle like it’s trying to load but can’t.

I set Browser Cache Expiration to 1 month but it didn’t help. Default of 4 hours didn’t help.

Page Rules:

  1. websiteurl/preview=true
    Browser Integrity Check: On, Browser Cache TTL: 30 minutes, Always Online: Off, Security Level: High, Cache Level: Bypass, Disable Apps, Disable Performance
  2. websiteurl/wp-admin
    Brower Integrity Check: On, Browser Cache TTL: 30 minutes, Always Online: Off, Security Level: High, Cache Level: Bypass, Disable Apps, Disable Performance
  3. websiteurl/*
    Cache Level: Cache Everything

Any suggestions? I’m wondering if I should just disable my WP Fast Cache plugin but I think there’s settings that help with gtmetrix that Cloudflare may not be able to do like minify CSS/Javascript or something. I’m totally stumped… I know it must be a cache issue… but I’m open to suggestions. Thanks so much everyone!

It looks like when I turn off the 3rd Page rule “Cache Everything” it works again…but wondering if turning it off completely removes the benefits of cloudflare even with the other 2 rules in place. Sorry for the questioning and thanks again. Is it ok to keep it off and still get the speed benefits of cloudflare?

Hi,

I don’t know if you have turned off the Cache Everything PR or not, but the page is not being cached by Cloudflare and yet the menu is not working properly. The reason seems to be unrelated to caching. It appears that when you click these menu items it tries to POST to Ajax, which is blocked somehow. If you navigate with Chrome’s dev tools open (F12), you’ll see:

POSTing to Ajax would be blocked by a WAF rule, so if you are in the Pro Plan or higher, that might be the case. If not, then check your firewall rules.

You may want to ask the WordPress theme or plugin support forum how to circumvent this without having to turn off the specific WAF rule.

1 Like

Wow thank you so much! I re-enabled the third page rule for Whole-page Caching… what’s strange is when I Purge the Cache it works…but after awhile it acts up again. I’ll contact the theme support hopefully they can help as well thank you!

2 Likes

This topic was automatically closed after 31 days. New replies are no longer allowed.