Website block

Hello,

We have Cloudflare with Domain name of ethiotss.org with {redacted} account login

When I Changed my DNS with NS lochlan.ns.cloudflare.com and NS macy.ns.cloudflare.com out email stop bouncing email but our website is blocked. Can you please help me to fix this Problem.

Thank you

I assume e-mail stopped working, right? Kindly, may I suggest looking into the below article if your e-mail records (usually the A mail being :grey: and the MX record pointed to this unproxied hostname) are configured properly while you are using Cloudflare for your domain name:

May I ask what kind of error do you get? Could you post a screenshot?

2 Likes

when I change the Cloudflare server names the email start working but the website not working or down

Interesting to see.

Before moving to Cloudflare, was your Website working over HTTPS connection?

May I ask what SSL option have you got selected under the SSL/TLS tab at Cloudflare dashboard for your domain ( Flexible, Full, Full Strict … )?

But, as far as I checked, the redirection is comming from WordPress - or better to say, one of your Plugins is causing this issue as well.

You have got Redirection Loops and possible Mixed content too:

>>> https://ethiotss.org

> --------------------------------------------
> 301 Moved Permanently
> --------------------------------------------
Status:	301 Moved Permanently
Code:	301
Date:	Tue, 14 Dec 2021 15:54:20 GMT
Content-Type:	text/html; charset=UTF-8
Connection:	close
expires:	Tue, 14 Dec 2021 16:54:20 GMT
cache-control:	max-age=3600
x-redirect-by:	WordPress
Location:	https://ethiotss.org/
host-header:	c2hhcmVkLmJsdWVob3N0LmNvbQ==
x-endurance-cache-level:	2
x-nginx-cache:	WordPress
CF-Cache-Status:	DYNAMIC
Expect-CT:	max-age=604800, report-uri="https://report-uri.cloudflare.com/cdn-cgi/beacon/expect-ct"
Report-To:	{"endpoints":[{"url":"https:\/\/a.nel.cloudflare.com\/report\/v3?s=nxRfhzaMk4DKEzU5TAk%2B%2BEXM%2FFpzzNh2qNbjlgkxClat3BYPgX9jm%2BsA7RPOPE9LA9y0ojSiZH07LumBfB32inXu3bTqYph2n5USS7u9yfQK6KuQEUx2ktqztwChk2Q%3D"}],"group":"cf-nel","max_age":604800}
NEL:	{"success_fraction":0,"report_to":"cf-nel","max_age":604800}
Server:	cloudflare
CF-RAY:	6bd89c2f5dc505d0-FRA
alt-svc:	h3=":443"; ma=86400, h3-29=":443"; ma=86400, h3-28=":443"; ma=86400, h3-27=":443"; ma=86400



>>> https://ethiotss.org/

> --------------------------------------------
> 301 Moved Permanently
> --------------------------------------------
Status:	301 Moved Permanently
Code:	301
Date:	Tue, 14 Dec 2021 15:54:22 GMT
Content-Type:	text/html; charset=UTF-8
Connection:	close
expires:	Tue, 14 Dec 2021 16:54:22 GMT
cache-control:	max-age=3600
x-redirect-by:	WordPress
Location:	https://ethiotss.org/
host-header:	c2hhcmVkLmJsdWVob3N0LmNvbQ==
x-endurance-cache-level:	2
x-nginx-cache:	WordPress
CF-Cache-Status:	DYNAMIC
Expect-CT:	max-age=604800, report-uri="https://report-uri.cloudflare.com/cdn-cgi/beacon/expect-ct"
Report-To:	{"endpoints":[{"url":"https:\/\/a.nel.cloudflare.com\/report\/v3?s=2KZlK%2BwmgpFnWa00u%2BVg6JnGgF5MMO4vXEE0lojZiEM1hHmyTVn%2FmJ5Di%2FgJtAa%2BcHN%2F2O162Z077cnRulda6Qso3yGQx9LS0NXU%2FlShD2STSeey8pGCIyfHIbEjn7Q%3D"}],"group":"cf-nel","max_age":604800}
NEL:	{"success_fraction":0,"report_to":"cf-nel","max_age":604800}
Server:	cloudflare
CF-RAY:	6bd89c391d5b3240-FRA
alt-svc:	h3=":443"; ma=86400, h3-29=":443"; ma=86400, h3-28=":443"; ma=86400, h3-27=":443"; ma=86400

19 loops as far as I see:

https://ethiotss.org
301 Moved Permanently
https://ethiotss.org/
301 Moved Permanently
https://ethiotss.org/
301 Moved Permanently
https://ethiotss.org/
301 Moved Permanently
https://ethiotss.org/
301 Moved Permanently
https://ethiotss.org/
301 Moved Permanently
https://ethiotss.org/
301 Moved Permanently
https://ethiotss.org/
301 Moved Permanently
https://ethiotss.org/
301 Moved Permanently
https://ethiotss.org/
301 Moved Permanently
https://ethiotss.org/
301 Moved Permanently
https://ethiotss.org/
301 Moved Permanently
https://ethiotss.org/
301 Moved Permanently
https://ethiotss.org/
301 Moved Permanently
https://ethiotss.org/
301 Moved Permanently
https://ethiotss.org/
301 Moved Permanently
https://ethiotss.org/
301 Moved Permanently
https://ethiotss.org/
301 Moved Permanently
https://ethiotss.org/
301 Moved Permanently
https://ethiotss.org/
301 Moved Permanently

yes the website was
working

when I changed the Name server to “apollo.ns.cloudflare.com” and
" liz.ns.cloudflare.com" the website start working but our email start bouncing

May I ask did you followed the instructions from my first post about e-mail troubleshooting and re-checked your DNS records at the DNS tab of Cloudflare dashboard for A mail (:grey:) and where does the MX record point to?

Therefore re-checked your e-mail client for incomming/outgoing server if it’s set to and using domain.com (:orange: record) or mail.domain.com (:grey: record)?

the MX record is
MX
ethiotss.org
mx2-us1.ppe-hosted.com
DNS only

2 min
Edit
MX
ethiotss.org
mx1-us1.ppe-hosted.com
DNS only

1 min
Edit

MX

ethiotss.org
mx2-us1.ppe-hosted.com

MX
ethiotss.org
mx1-us1.ppe-hosted.com

I did but is not working

As asked by @fritex 3 hours ago, what do you have set under the SSL/TLS at the Cloudflare dashboard for your domain?

pleasedon’tsayflexablepleasedon’tsayflexable

I saw at one moment, you were using - or that one was old record - MS Outlook protection for MX record (e-mails)?

So, is your e-mail provider ethiotss-org.mail.protection.outlook.com. or rather is ppe-hosted?

ethiotss.org. 300 IN MX 0 ethiotss-org.mail.protection.outlook.com.

Nevertheless, I see currently you are using Cloudflare nameservers:

 ;QUESTION
ethiotss.org. IN NS
;ANSWER
ethiotss.org. 21600 IN NS apollo.ns.cloudflare.com.
ethiotss.org. 21600 IN NS liz.ns.cloudflare.com.

Therefore, for the A www and A ethiotss.org both are either set to :grey: (DNS-only) or you enabled the Pause Cloudflare for this site option at the Cloudflare dashboard?

I see your website loading fine over HTTPS:

Please, navigate to the SSL/TLS tab and select Full (Strict) SSL if not already.
Switch back to :orange: so we could check for redirect loops after you change the SSL settings and make the records proxied.

Nevertheless, are you using some WordPress plugins like Yoast SEO, Really Simple SSL, etc.?

The redirection was before from WordPress (already stated):

x-redirect-by:	WordPress

Current MX record is

;QUESTION
ethiotss.org. IN MX
;ANSWER
ethiotss.org. 300 IN MX 0 ethiotss-org.mail.protection.outlook.com.

Record A mail is not being used / missing.

May I ask how did you test to send/receive your e-mails?
Have you re-checked your POP3/IMAP/SMTP server in your e-mail client?
Have you looked into the articles for e-mail troubleshooting from my first post?

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.