Website blank


#1

Hey guys,

This is my first time using Cloudflare and I have no idea what’s going on.
When I go to my website https://varand.me/ it takes me to a blank page, however, I can’t find that folder in my server. I have removed all cgi-bins. Not sure what folder that’s being taken too. But, when you go to mail.varand.me it shows me my actual site. I’m not concerned about mail(dot)varand(dot)me not taking me to my email, because that’s something I have to configure on namecheap, but I’m not sure what’s going on with the homepage. Can someone please help?


#2

Was your site set to HTTPS before you switched to Cloudflare? Which SSL Setting are you using?

Try setting it to Flexible and see what happens.


#3

I saw using the full setting and I just changed it to flexible. Also, I was using let’s encrypt, but I uninstalled the certificate and deleted the full .htaccess file.


#4

Why did you uninstall the certificate and delete .htaccess? Cloudflare will proxy your website as is.

I see that it’s working in Flexible mode, so that’s good. But if you can get that Let’s Encrypt certificate back on your server, you will be able to set SSL back to Full (Strict) and have full end-to-end encryption.


#5

I’m pretty new to SSL/TLS certificates and I thought that the Let’s Encrypt certificate would interfere with Cloudflare.

I’ve gone ahead and gotten the certificate back from Let’s Encrypt and changed my settings to Full (Strict), but I’m still getting a message, “Your connection to this site is not fully secure.”


#6

It’s not fully secure because you’re loading a dozen or so resources from webflow using HTTP.

On the Cloudflare Crypto page, you probably already turned on Always Use HTTPS, but check if “Automatic HTTPS Rewrites” is on. That might fix it. If not, you’l have to find a way to change those webflow references to HTTPS.


#7

This topic was automatically closed after 14 days. New replies are no longer allowed.