Website becomes very slow


#1

Hello everybody,

I am experiencing an issue, that occurs quite randomly, but more and more since a few days. My website becomes very slow sometimes, with a Fully Loaded Time of 15s wheareas normally it is around 2-4s. And I found that it comes from Cloudflare. When I’m playing with options, it goes better as you can see on those reports from GTMetrix :

Full activated
UK server : https://gtmetrix.com/reports/www.larbreetlapirogue.fr/YBmtF8ps
Canadian server : https://gtmetrix.com/reports/www.larbreetlapirogue.fr/VKirgkOy

Rocket loader disabled
UK server : https://gtmetrix.com/reports/www.larbreetlapirogue.fr/l62sxkBN
Canadian server : https://gtmetrix.com/reports/www.larbreetlapirogue.fr/InmNHcPz

SG Railgun AMS off :
UK server : https://gtmetrix.com/reports/www.larbreetlapirogue.fr/b6RKcg6V
Canadian server : https://gtmetrix.com/reports/www.larbreetlapirogue.fr/5mhBdItU

Pause website :
UK server : https://gtmetrix.com/reports/www.larbreetlapirogue.fr/o07dIVBF
Canadian server : https://gtmetrix.com/reports/www.larbreetlapirogue.fr/DGCENg3b

As you see, the website’s speed increases by disabling some options… to be very fast when I pause the website. My host is Siteground, I use a wordpress, and the website is new, so : not a lot of plugins (speed booster and wp super cache), not a big database.

Do you have some ideas to fix this issue ?


#2

Check the Waterfall. Your page is actually not loading that slow, images seems to be cached and respond fast.

Your culprit is the initial request which is the HTML HOME PAGE of your site. Do you cache that with speed module, that can improve it, because you are probably running on a shared server, and you will see variate times. Cloudflare doesn’t cache your HOME PAGE, currently if you don’t have set up Page Rules, but for an eCommerce site I wouldn’t recommend that, if you don’t know how to do it properly.


#3

@n.stojanovski I am very new to this kind of technics, so I’m afraid i did not understand everything you have said.

Normally everything is cached. Yes, I’m running on a shared server, I can understand it should come from this, but why does it happen when cloudflare is enabled only ?
About Page Rules, i don’t know anything about it, I think I can be documented here ?

I’ve done what it is recommended in the last post from this topic, and for now, it is working…


#4

Thanks for linking to that post, that lead that I investigated and disabled Cloudflare in cPanel. Now I’m the last post in the topic. :slight_smile:


#5

And to end with this, I found a post that can help : How to set up cloudflare to cache wordpress ; it also talks about the page rules.

You can see the result here : https://gtmetrix.com/reports/www.larbreetlapirogue.fr/0jbwBOhl

:slight_smile:


#6

This topic was automatically closed after 14 days. New replies are no longer allowed.