Webserver raspberry pi - cloudflare CNAME 'record invalid'

So the cloudflare blog has a DIY article to setup web server with a Pi which is here; https://blog.cloudflare.com/dyi-web-server-raspberry-pi-cloudflare/

at the bottom it links to this page; https://www.instructables.com/59-Web-Server-with-Amazon-Class-Performance-Securi/

i followed all these steps to step 10 where i’m running into a problem.

Under the value column where it says “points to” type the internet address of your Pi from the prior step that you were asked to write down in step seven, then click save. Make sure you do this for both the “A” record and the “CNAME” record with the “www” value.

It doesn’t let me put in my IP for CNAME. Is this an error from the author? Do I use my domain name for the CNAME and NOT my IP address? I put my IP for the “A” record as instructed.

Thanks

A CNAME record does not have an IP address but a proper hostname. You’ll need an A record instead.

so I put the IP for “A” record. for the content IPv4 address. and my domain under the ‘name’

don’t think you read the quote from the article im referring to. he says to put the IP for A and CNAME

It really is all covered at Adding DNS Records.

you haven’t read what im referring to. im following the instructions to set up a raspberry pi- you’re not helping at all. please move along

I think you are in the wrong place if you do not like the advice you are given.

You asked if you can use an IP address with a CNAME and I answered that.

Actually that’s not even a Cloudflare related question and should not be asked here.

But don’t fret, with your kind attitude I’ll make sure I won’t bother you in the future any more :roll_eyes:.

clearly you didnt read my original post.

I SAID the instructions that the cloudflare blog linked to, said to put the IP for both the A and CNAME records.

and it obviously doesnt let you choose to put an IP for cname.

setting the A record as my IP. setting the CNAME as my domain name. and setting my domain registrar nameservers as the ones provided to me by cloudflare- has not achieved what im trying to do.

Where does the Cloudflare blog say you should use an IP address for a CNAME record?

there you go again NOT reading what i laid out.

again; i said the instructions that the cloudflare blog LINKED TO

Once more where does it say that?

You quoted

Make sure you do this for both the “A” record and the “CNAME” record with the “www” value.

and that’s correct. The IP goes into the A record and the hostname into the CNAME record.

You seem to be confused.

and all the links for the blog article and the instructions article the blog linked to are provided in my post.

you are not reading the whole post, just scanning thru it- your not helping whomever this way

RIGHT HERE. if your read the instructions it says to use the IP from step 7!!

Under the value column where it says “points to” type the internet address of your Pi from the prior step that you were asked to write down in step seven,

There’s no “points to” field, only a summary. But if that suggested to use an IP address for a CNAME record that would be obviously wrong, as I already pointed out.

Not sure what your question is. As already mentioned, you have to use an A record for an IP address.

It literally says “type the internet address of your Pi from the prior step” meaning step 7.

and then goes onto say to do so for both the A and CNAME record.

you must be confused

You seem to want to argue and the forum is not the right place for that.

Closing as the question has been addressed.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.