Webserver is not opening via domain which is on CF


Today I have installed the LAMP stack on Ubuntu distro on a new server. This went well as far as I could verify.
Then I configured subdomain. sub.mydomain.com on a domain which is already on Cloudflare. Since the installation was on a new IP (not the one my main domain is running on) I created a A record for this subdomain.

But…when I navigate to the IP adres, I can see my Apache default page but when I do that via sub.mydomain.com it throws a 521 error Error 521 ## Web server is down.But I can see it serves https from the SSL of CF.

What am I doing wrong here? I expect to see the same default page of Apache.

Cloudflare proxies your domain so it’s normal that there’s a CF certificate showing up. Check the server configuration

A 521 error happens when Cloudflare is unable to make a TCP connection to your origin server. Review the suggestions in this Community Tip for Quick Fix Ideas.

1 Like

I confirmed that port 443 is open. webserver is UP. I also have whitelisted CF IP ranges.
Still I receive a 521 https://account.klazinamedia.com/

Is this still an issue?

Hey Mark,

Issue is solved. I followed this link https://www.digitalocean.com/community/tutorials/how-to-create-a-self-signed-ssl-certificate-for-apache-in-ubuntu-18-04

NOTE: by opening FW rules the issue was solved but I also kicked disable port 22/ssh so now I have other problems

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.