Webp: it says type is webp, but no CF in headers and google pagespeed flags

New to CF 2 days ago. I purged cache

TLDR: Image inspector and Chome Dev Network says image/webp. But only my logo has the CF tags, and google Pagespeed is calling out these same images as not being webp compressed.

So

Checking my site http://42freeway.com with chrome dev tools… Scroll down to load the 6 article previews and look in Network tab at the 6 larger featured images.

I can see the content type is webp. But if I look at responses… only my logo 42Freeway-Com.jpg has the extra CF tags. 5 CF tags to be exact. Perfect.

But none of the other featured images have the CF response tags

Maybe easier to see when clicking/displaying a single article… easy to pick out featured image header.
Similarly… no CF tags in response. But the logo has them

The site seems very fast… but google pagespeed is hammering me images not being webp. Literally the only reason I signed up for CF Pro is to get my pagespeed scores higher.

Any help would be appreciated

EDIT: Added TLDR at the top

  1. They’re webp (see image below)
  2. I wouldn’t count on Pagespeed Insights to accurately assess the nuances of a page (it has irritating limitations)
  3. First visit might not be webp because Cloudflare only converts cached images.
  4. Try testing using Chrome Lighthouse from your browser’s Dev Tools (F12).

2 Likes

Ty… so this is Lighthouse.
Just ran a report on my homepage. The important score is 73. I was in the 80s before I turned on CF.

They are calling out that I dont have webp images for these images… when yea, indications seem to be that I do. I posted here because I do not see the CF attributes in the response.

Normally I would just say “eh no problem, the site is def fast for users”. My concern is the May 2021 core web vitals turn on… and Google thinks I am below the standards.

Lighthouse web.dev results

You have removed the top line so we can actually not see what was written there and what exactly Lighthouse wanted you to improve at this Images.

It also could be the case that your Images (even if they are webp) are nor scaled right.

If you just recently switched to CloudFlare your CF-NameServer may not be propagated at your own DNS.
But CF-Tags/Headers are all set:


So your WebP settings are:
“Lossless” which is perfect!

Please test again and report back if now Lighthouse detects everything correct.

2 Likes

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.