Webp images not being displayed after pro upgrade

I just upgraded to the pro plan so my images would be served in webp format.

I have enabled polish with lossy compression & enabled webp converion.

However when I check the google page speed insights for this example page it is still not picking up webp image formats being offered.

https://developers.google.com/speed/pagespeed/insights/?url=https%3A%2F%2Flivingunrefined.com%2F100-crazy-things-to-do-before-you-die%2F&tab=desktop

The status header being returned says status=vary_header_present:

vary: Accept-Encoding
vary: User-Agent,Origin,Accept-Encoding

Only the Accept-Encoding header is allowed.

1 Like

hi thanks, you have lost me here tho

can you clarify what my status header return is & what it should be pls?

ok I think I found the conflict now, there was an entry in htaccess for the user-agent,origin,accept-encoding

However I am still not seeing webp images - could you please take another look?

I see WebP Images: https://livingunrefined.com/wp-content/uploads/2020/05/things-to-do-when-your-bored-1-300x197.jpg
The Type of this URL is webp:

2 Likes

hi many thanks for taking a look, I am also now seeing mixed Webp images on some pages, others not.

This particular page never loads a webp image, but I know when I did a manual conversion it went from 500kb as png to 80kb as webp image.

I have set to lossy conversion so if all working well the main image on this page should always be webp right?

Which image was that? Every image on that page shows up as WebP.

it was the second one down crazy_things_to_do_before_you_die.png

I am basing it off page speed insights:

https://developers.google.com/speed/pagespeed/insights/?url=https%3A%2F%2Flivingunrefined.com%2F100-crazy-things-to-do-before-you-die%2F&tab=desktop

Now I’m getting a 403 on the source image for that, and some others.

I don’t see that error - I have been refreshing the cache quite a lot over the last hour as I work on other things. Maybe just a temporary restriction? Or is it giving 403 consistently?

I guess that was it. They’re loading now.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.