Webmail time out

Hello, all the domains we proxied through cloudlfare from 2020 to 2021 have their webmails working without issues. Except the last 2 we proxied the past month feb-march 2022.

We will continually get timeout … but things would work fine when we stop the proxy. What could be the issue and how to effectively solve them?

We reached out cpanel team they said something is blocking networking between Cloudflare and our servers. we looked could not find anything. Please someone advise. Thank you

someone please help advise to solve the issue.
Thank you

Is this related to cPanel Webmail or rather receiving/sending emails?

What error do you get?
Could you reply with a screenshot?

If it is a sub-domain like webmail.domain.com or domain.com/webmail, does it work over HTTPS when you temporary disable the proxy :orange: and switch to the :grey: (DNS-only)?

If so, may I ask you to check if the SSL certificate valid of it?

Are you accessing to it via 2083, or rather 2096 port?

Try to disable the ModSecurity.

Furthermore, do not skip below step and kindly re-check if Cloudflare is allowed to connect to your origin host to as follows in the below article:

Nevertheless, Cloudflare IP addresses list can be found here:

Otherwise, kindly re-check your Firewall events at Cloudflare dashboard if there is some challenged or blocked request.

Furthermore, I’d suggest you to disable :orange: and use :grey: (DNS-only) for your webmail.
Otherwise, create a Page Rule to redirect any request matching “webmail” to your hosting provider domain and port to access webmails.

1 Like

Thank you @fritex

> Is this related to cPanel Webmail or rather receiving/sending emails?
Yes only to webmail.domain.com

What error do you get?
Could you reply with a screenshot?

If it is a sub-domain like webmail.domain.comordomain.com/webmail , does it work over HTTPS when you temporary disable the proxy :orange: and switch to the :grey: (DNS-only)?
Well, we’re using the Origin server SSL so disabling proxy shoots SSL error, but still works… screen attached

If so, may I ask you to check if the SSL certificate valid of it?
yes valid. checked at sslshopper.com

Are you accessing to it via 2083, or rather 2096 port?
2096 ( webmail.domain.com) in this case we learned that these ports are opened from CF by default

Try to disable the ModSecurity.
Did so… nothing here. We’re using CSF.

> Furthermore, do not skip below step and kindly re-check if Cloudflare is allowed to connect to your origin host to as follows in the below article:
Yes it is. Because we have deliberately set the ip for CF. Lately we also received an email concerning IP changes from CF which we also updated in our server.

We have 11 domains going through CF. 9 works without issue, but only the 2 last newly made about a month ago are experiencing such issues. We ended up disabling altogether CF for one of them, and everything works, and trying to find out where the issue lies with the other one experiencing the difficulties.

Otherwise, kindly re-check your Firewall events at Cloudflare dashboard if there is some challenged or blocked request.
There is ONLY a firewall on 1 particular domain in CF which denies all requests from oversea IP. However that specific domain does NOT have any issues with webmail.domain.com

Other than that, we replicated the exact parameters as it works for all others but the last 2 won’t on webmail.domain.com

All the points you’ve mentioned we’ve checked… prior posting the thread… and still nothing.
We reached out to cpanel could not identified the EXACT issue, so it was only ASSUMED.

Just don’t know what, where is the issue coming from.

Thank you for feedback information.

If so, may I ask what SSL option have you got selected under the SSL/TLS tab at Cloudflare dashboard for your domain ( Flexible, Full, Full Strict … )?

If so, may I ask what SSL option have you got selected under the [SSL/TLS tab](https://dash.cloudflare.com/?to=/:account/:zone/ssl-tls) at Cloudflare dashboard for your domain ( *Flexible, Full, Full Strict …* )?

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.