Webmail not accessible anymore

Hello everyone,

I just switched a website i am actually building to Cloudflare services. I am trying the free plan first to see how evrything works and i am facing a problem i have not find answer to. I see this problem raising here and there on a regular basis but no clear answer.

My problem is i can’t access my webmail after switching to Cloudflare, being http or https.
Address type is : webmail.example.c o m

MX records and A record for mail are perfectly ok and i can receive and send emails with outlook clients, no problem with that.
I also added a : A Webmail x.x.x.x (ip address) so i can reach my webmail.

But nothing work so i may have done something wrong or missing a setting somewhere. For the record, i am using Plesk to administrate my server.

If someone wanna help me, i will greatly appreciate it :slight_smile:

Thanks community
Matt

Greetings,

Thank you for asking.

I am sorry to hear you’re experiencing an issue.

Thank you for feedback information.

Was your webmail sub-domain working over HTTPS before you switched to Cloudflare nameservers and before you’ve proxied :orange: that hostname? :thinking:

May I ask what SSL option have you got selected under the SSL/TLS tab at Cloudflare dashboard for your domain ( Flexible, Full, Full Strict … )?

May I ask have you tried using a different Web browser, or tried clearing your Web browser cache?
How about using a Private window (Incognito mode) or a VPN connection if possible?
Is it the same behaviour on your mobile phone (4G LTE, mobile data, cellular)?

Do you get some error in your Web browser? If so, which one, could you share a screenshot of it here with us?