Webmail Didn't Work


I changed my server and my website crashed. Afterwards, the problem persisted even though I renewed my IP addresses. That’s why I deleted my site from Cloudflare and added it again. My web page is active now, but I cannot reach my e-mails. Webmail is not working. I had forwarded to my mail account before and when I send mail for testing, it is delivered to the account I forwarded. I think the problem is only in Webmail. However, I couldn’t find any solution. How can I solve it?

Thanks in advance for the solution. You can see my DNS settings in the attachment.

From your screenshot above, I see familiar DNS records.

But, unfortunately I do not see any A webmail DNS record - which could be the case it’s missing and the reason why your Webmail is not working so far.

May I ask have you tried accessing webmail.bytenpixel.com or maybe bytenpixel.com/webmail (if used this URL, you might be missing an redirection rule, or you could create a Page Rule here at Cloudflare dashboard to redirect it to the required path)?

I would suggest you to add an A webmail record pointed to your hosting/email IP. Wait for few minutes or an hour (to properly propagate) and re-check if it’s working again.

May I ask are you using any other e-mail client to send/receive e-mails like MS Outlook, Mozilla Thunderbird, etc., or only via Webmail?

May I share my post here containing useful information about proper steps to e-mail setup for your domain name while using Cloudflare:

1 Like

Actually, the DNS fields here are the same as before my IP address changed. I was able to use Webmail before my IP address changed. Just as an extra, I ran the wizards for the error-missing information messages above the DNS field. In other words, the bottom 3 TXT fields in the picture have been added.

I tested recently, webmail.bytenpixel.com can be accessed, but only over HTTP, not HTTPS.

And it seems to me the DNS record A webmail is set to :grey: (DNS-only)?



Yes, I added A webmail tag and webmail page is working now. But I can’t log in. Link changing to “http://webmail.bytenpixel.com/cpsess2818944619/3rdparty/roundcube/index.php?login=1&post_login=16897071527072” and showing login screen again.

And yes, A webmail is DNS-only. Is there any way to redirect to https too?


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.