Webmail broken since Cloudflare

Hello all, since activating cloudflare my webmail isn’t working. It accepts the user/pass (definitely correct), then hangs on ‘redirecting’ until I get a timeout message. My email IS still working via Thunderbird. My website is theworkswebdesign . com

Make sure your encryption mode is Full Strict.

Thanks for the reply. I changed that as you suggested, but unfortunately it hasn’t made a difference

Can you post a URL where that can be reproduced?

It only shows up when you’re logging in to webmail, so unable to provide the details to reproduce. I tried turning off proxying to the webmail A record and it immediately came back. Switched proxying back on, and it breaks again. Does that help narrow it down?

Can you provide a dummy login? Otherwise it will be impossible to debug that.

You could check if you have a page rules which enforces an insecure legacy encryptoin mode. If so, drop that rule and make sure you are using Full Strict. Also, make sure your server is actually rewriting IP addresses, otherwise it may be an IP address related issue.

Yes here is a dummy account:

User: cf @ theworkswebdesign . com
Pass: 6rcyKkWihe!,


webmail . theworkswebdesign . com

The issue also occurs when connecting directly and your server returns a 500. This will be most likely because your server may be connecting to itself and will run into issues when its own DNS entry is proxied. I am afraid that’s something you’d need to debug on your server. Can you unproxy the DNS entry just to verify?

Unproxied now

All right, when connecting via the proxies right now it actually works. So the issue is what I mentioned earlier and your server will connect to itself and won’t like the proxies. I am afraid you will have to debug this on your server as this is not Cloudflare related. You probably best disable that feature or you use your actual server IP address instead of the hostname.

Thanks for this. Since disabling it makes it work again, is there any disadvantage to disabling the proxy just for the webmail A record? It says it exposes the IP, but the IP was fully exposed beforehand, so… what?

That warning is primarily if you want to keep your address from the public, however here the address is already archived with different services anyhow, so there’s little point in that, unless you changed the address.

If you can’t fix the server issue, keeping it unproxied is probably the easiest way to “fix” that.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.