Webhook FastSpring called worker function and returned -- ERROR -- Script is invalid Error :Received fatal alert: handshake_failure

I’m using FastSpring for my payment option, and upon to successful payment webhook of Fastspring should call cloudfare worker function and return license key to end user.
When I try to call Worker function from fastspring webhook I have error
– ERROR –
**Script is invalid **
Error :Received fatal alert: handshake_failure
I checked TLS version and set it to 1.2 as well as I confirmed that there is at least one chipper suite from fastspring list that supports cloudfare worker function.
Worker function is using custom route worker.mydomain.com and everywhere is working except the fastspring webhook call.
Here is report of worker function what protocols and chipper suite supports. and here is the list of fastspring chiper suites Troubleshooting Webhook Connection Problems | FastSpring Docs


Anyone had similar issue how to solve this so I’m able to make a call from fastspring webhook to cloudfare function?

anyone?

small update… this error happens only if I use type="webpack" if I don’t use npm modules and user regular type="javascript" it works fine

Hello, is that connection error coming from FastSpring? Are you able to visit your subdomain yourself?

If you could share the subdomain we can take a better look but as long as the DNS record exists, it should connect just fine.

Yes it’s coming from Fastspring, and yes I’m available to make a call to function from anywhere except from FastStpring.
This is subdomain -test4142.workers.dev I even made custom route with DNS

and tried with custom route to call from fastspring but still the same

Have you setup a route for your Worker? Be aware that doing a CNAME record is not how you fire a Worker. You do need a proxied record however you will also need to setup a route here: https://dash.cloudflare.com?to=/:account/:zone/workers

Do you have a route setup exactly like I’m showing here?

yes I did, otherwise I couldn’t make a request to a function from Postman, and calling from Postman is working

I’m seeing an SSL issue on my end which would explain connection failures. This should be covered by the Universal SSL certificate.

Can you confirm the Universal SSL cert is enabled?
https://dash.cloudflare.com/?to=/:account/:zone/ssl-tls/edge-certificates

Thanks for answering, and yes it’s universal SSL Certificate

I’m not sure why that was throwing SSL errors for a while however, it now seems to be properly secure and resolving. There is an exception being thrown in the Worker itself now but the connection is all good!

I’m struggling with this for days, and so far I managed to call Worker from Fastspring only if webpack isn’t used, so is it possible that this webpack in background generates something that is causing this handshake failure in Fastspring?
Because even in the cloudfare tutorial there is written to use javascript not webpack, but for me it’s not possible to run with javascript if I use npm modules