Webflow failed to connect cause DNSSEC

I got error on my Webflow sites

Previously I was not handled my own Domain and records config. Then I migrated my Domain ownership. But turns out, some config before me put into this condition.

Have anyone setup Webflow with Cloudflare?


Welcome to the Cloudflare Community. :logodrop:

You need to fix your DNSSEC at your registrar.


How to fix it? Just disable it from Settings?

Why could this be happen?

Your problem is caused by your registrar having invalid DNSSEC material. You need to replace it with valid material. The article linked has directions on how to enable (not disable) DNSSEC in Cloudflare, so that you will have valid DNSSEC material to submit to your registrar.


Somewhere from the settings of the domain registrar (the ones you pay for the domain to), you should be able to disable DNSSEC. Apparently, this would be with Registrasi Neva Angkasa (https://rna.id).

Or even better, keep it enabled on Cloudflare, and update the settings at the registrar to match the new settings.

Switching e.g. provider of name servers requires certain changes to the DNSSEC configuration at the domain registry, as the old provider would have the private key material matching the (old) set up, but the new one wouldn’t.

As such, disabling DNSSEC might be the best option, to avoid issues when you transfer domains, or change name servers.

The domain was apparently with lady.ns.cloudflare.com and jim.ns.cloudflare.com, some days to a week ago.

The name servers has now been changed to brynne.ns.cloudflare.com and howard.ns.cloudflare.com.

1 Like

Thanks, I think I already solved it.
Enable DNSSEC in “new Cloudflare” account, then disabled it after it already registered DS.

As @epic.network said before, I need to replace with “valid material”.
So it seems come handy just to re-activated DNSSEC

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.