Web server is returning an unknown error - error code 520

Dear Cloudflare Support Team,

I hope this message finds you well. I am experiencing an issue with my website, and I believe it is related to Cloudflare’s cache and my origin web server. The error message displayed to visitors is as follows:

“There is an unknown connection issue between Cloudflare and the origin web server. As a result, the web page cannot be displayed.”

Details:

Steps Taken:

  1. I have reviewed my DNS records in Cloudflare, and they appear to be correct.
  2. I checked the headers and cookies sent by my server and ensured they are within acceptable limits.
  3. I have examined my server logs, but I need further assistance in identifying the root cause.

Request: Could you please investigate this issue and guide me on how to resolve it? If necessary, I can provide the error log from my web server for your analysis.

Your prompt attention to this matter would be greatly appreciated. Thank you for your assistance.

Best regards,

I think this topic is being rehashed in previous posts, but I would try the quick workaround of making the record DNS-only or pausing Cloudflare then disabling Always online in the dashboard. and clear cookies and cached image data in chrome setting privacy and security. as you investigate the issue

Disable Cloudflare
Restart The webserver.
Remove plugins.
Make sure DNS is set properly.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.