Web Forwarding for anything.thisdomain.net

Okay, so we have a few domains that are just for pointing to the main domain.
For example - mydomain dot com is the main domain and we have mydomain dot org, thisdomain dot net and myotherdomain dotnet

The other domains should point all traffic to the main domain - however, this isn’t working as expected. I have one CNAME on thisdomain dot net (proxied) that points to mydomain dot com and page rules set:

So, supposedly, anything typed in a browser should get pointed to the right page on mydomain dot com, right?
What am I missing?
Because in testing, thisdomain dot net goes where it should, www.thisdomain dot net might get there, but anything.thisdomain dot net doesn’t go anywhere.
I have gone to one A record that points to a random IP, one CNAME record that points to the target domain, etc. Still can’t get something.thisdomain dot net to get to the right place.

Even pinging - thisdomain dot net resolves, www.thisdomain dot net doesn’t, anything.thisdomain dot net doesn’t.

It looks like the “Any” (wildcard) dns resolution is a premium feature and we are only using free for the supplemental domains.

Hello,

https://support.cloudflare.com/hc/en-us/articles/200172286-Configuring-URL-forwarding-or-redirects-with-Cloudflare-Page-Rules

Have you got only one domain (main) added to the Cloudflare?
What about others?

  1. Add all of the domains to your Cloudflare account.
  2. Create A www and A yourdomain.com (yourotherdomain.net, youranother.org …) records for each of them and point to an IP address of the host/origin and make sure they are :orange: proxied.
  3. Also, at each one of them you create a Page Rule which does the Forwarding URL -> 301 redirection for the each request made at thisdomain.net/*, mydomain.org/*, yourotherdomain.net/* to your https://www.maindomain.com/.

A CNAME itself does not do a redirect. You would need a :orange: Proxied DNS record for “www” of your domain and then a Page Rule like
Match: www.anotherdomain.net/* and a Setting of Forwarding URL to: https://www.yourmaindomain.com/$1

The $1 part should forward the path as well if you’d like.

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.