Web Browser stalling for UK customers when proxy enabled

Hi -
We run a SaaS app serving customers all over the world. Since last week (around the 30th May) UK users have been complaining about slow / failed page loads in our app.

We have been able to replicate and can see chrome / safari browser network stalls for anywhere between 10-40 seconds on random pages inside the app.

No ryme or reason to which page causes this. It happens after 1-5 clicks around the site.

If you enable a VPN then the site works fine.

We are starting to suspect a possible issue with BT (UK ISP) network users + cloudflare proxy?

It sounds like a very similar issue to what others have mentioned before.
e.g.

and this issue:

Can anybody help? I can see London is still showing as partially re-routed post the recent maintenance. Is this issue related to that?

Super keen to figure this out otherwise we might need to consider moving off Cloudflare.

I have submitted a ticket here a few days ago. https://support.cloudflare.com/hc/en-us/requests/3286712

Many thanks in advance.

Sorry posted the wrong link - here is the issue another user was facing Cloudflare Proxy suddenly breaks our site

@user8062 - sorry to bother you. Did you find a resolution to this issue? We’re seeing very similar right now.

Hi there,
it’s frustrating to see that you’re running into what appears to be a similar issue to ours.

For me, this issue has to rank amongst the most frustrating customer service experiences of my life, and I’ve worked in and on the web for 25 years.

Did we resolve the issue? Yes, but I am not sure how. After ‘sandro’ shut down my initial ticket in the most rudest of ways I fell back on to Cloudflare’s ticketing system. I also complained about sandro’s behaviour, to no avail. It says a lot about the company. Rant over.

I had a ticket open from November 2023 until January 2024 during which time I tried to get network capture’s from a customer’s machine. This proved difficult. We turned all Cloudflare proxying off which opened our site up to the usual script and bot activity. Not good.

Eventually I was consistenyl able to reproduce the issue on all of my machines as well. I opened another ticket in the middle of February and this stayed open until the end of March, with 36 back and forth replies. Support asked me to provide HAR captures, which I did. They wanted screenshot. I provided them.

They wanted more HAR captures. I provided them.
They then came back and said

The team examined the latest 3 HARs and observed client-side stalling before even a DNS lookup, per the original ticket description. Neither HARs nor the edge will have any information about local browser conditions that would cause such a stall. A NetLog might.

I went ahead and provided the Netlog capture. If it helps, I used this command

open -na "Google Chrome" --args --user-data-dir="$PROFILE_PATH" --disable-fre --no-default-browser-check --no-first-run --log-net-log="$NETLOG_FILE" --auto-open-devtools-for-tabs $1

I later sent them anotgher capture for good measure.
Every time I had to refresh the browser a few times, then it hang. Always. Reliably.

I supplied the Netlogs on March 13th. On March 14th I was no longer able to reproduce the issue.
By the way, the problem reliably occurred even on Cloudflare’s own /cdn-cgi/trace route, one that doesn’t even access our server, totally eliminating it as a potential source.

The next day I was still unable to reproduce the issue so I asked them if they had fixed anything.

The situation seems to be that we don’t have anything broken at present, and don’t have any reproduction of an error.
We weren’t able to turn up anything from the last round of netlogs and without being able to reproduce for fresh netlogs, we won’t be able to provide a root cause unfortunately.
I’m afraid our Protocols team can’t do anything at the moment, therefore.

I cannot understand how a specialised team cannot deduce any clues from a Netlog dump that reliably showed the issue.

I never heard back after that. Our issue remains resolved and apparently nobody has made any changes whatsoever. It was a massive coincidence then that the issue was resolved exactly the day after I submitted my Netlog files…

I’m afraid I don’t believe in coincidences. If I was you I’d gather HAR and Netlog dumps and send them to support. They clearly have an issue.

Can you tell me (maybe PM me) the domain you are having issues with? I used a dedicated subdomain to test the problem, one that no customer was accessing.

Try and reproduce it on Free classifieds - yourdomain.com because that eliminates your own website as a source of the problem.

You’re welcome to email me directly. stefan dot richter at gmail dot com

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.