We have set up page rules to cache more aggressively but not working

We are informed by CloudFlare that our website is running slowly and that we should enable page rules to speed up loading of pages. So we enabled using the pretty good help document here:

We added Cache Level: Bypass for the login page and admin page for our WordPress and then Cache Level: Cache Everything, but it doesn’t appear to have had an effect yet. I notice that there are other settings such as Bypass Cache on Cookie for business and enterprise users, but shouldn’t the above also work OK for a WordPress environment? Do we need to add something else like Edge Cache TTL? Does it take a while for this to take effect?

What’s the domain? And can you post a screen shot of your Page Rules?

Sorry for the delay. reachinschools.org is the domain. I have attached a screen shot of the rules applied.

Your server is sending a no-cache header: