We are attempting

Answer these questions to help the Community help you with Security questions.

*Have you searched for an answer? Yes

*Describe the issue you are having: We are attempting to restrict access to the domain from specific countries using a custom rule in the Web Application Firewall (WAF). However, despite adding the rule, we are still able to reach the domain from those particular regions.

*What error message or number are you receiving? Not getting any error

What are the steps to reproduce the error:

  1. Create a new custom rule in WAF
  2. Country is in any country
  3. Hostname contains subdomain.domain.com
  4. Action: Block

*Have you tried from another browser and/or incognito mode? Yes

*Please attach a screenshot of the error: No error

Could you share the expression and/or screenshot of your WAF Rule? :thinking:

Is it the only rule or you’ve got some more of them?

Is it the frist from the top on the list of your WAF rules? I ask because of the order & priority of execution.

Nevertheless, is the subdomain.domain.com proxied and :orange: ? :thinking:

1 Like

Could you share the expression and/or screenshot of your WAF Rule? :thinking:

Is it the only rule or you’ve got some more of them?
=> Only one rule is present

Is it the first from the top on the list of your WAF rules? I ask because of the order & priority of execution.
=> Yeah, its the first one

Nevertheless, is the subdomain.domain.com proxied and :orange: ? :thinking:
=> Its not proxied and the domain present in cloudflare

The rules are executed on the Cloudflare proxy, so it is impossible for them to have any effect on a :grey: DNS Only hostname.

You can only use the WAF with :orange: Proxied hostnames.

2 Likes

Thanks, it worked after updating the proxy status

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.