Was getting 302 now getting 502 - Please Help!

Hi All,

I have a cloudflared tunnel with full (strict) with origin certs downloaded that I’ve confirmed can get to my Rpi4 and have installed Nextcloudpi through the install script. My Rpi4 is Raspbian OS 64 Bullseye. The ddns site is registered to a .ml domain, which means that you cannot setup the tunnel with domain type like this through website - but need a config.yml file to configure properly.

The main issue that I’m having is that I cannot seem to have the ddns direct to the nextcloud instance and I keep getting the redirect error message that doesn’t allow it to securely bring up the page…with the current configuration below I’m getting a bad gateway error message and not able to pull up site, could really use some help please!

Apache2 site redacted below:

<IfModule mod_ssl.c>
  <VirtualHost _default_:443>
    ServerName nextcloudpi.local
    DocumentRoot /var/www/nextcloud
    CustomLog /var/log/apache2/nc-access.log combined
    ErrorLog  /var/log/apache2/nc-error.log
    SSLEngine on
    SSLProxyEngine on
    SSLCertificateFile   /home/$USER/Documents/sub.domain.com.pem
    SSLCertificateKeyFile /home/$USER/Documents/sub.domain.com.key

    # For notify_push app in NC21
    ProxyPass /push/ws ws://127.0.0.1:7867/ws
    ProxyPass /push/ http://127.0.0.1:7867/
    ProxyPassReverse /push/ http://127.0.0.1:7867/
  </VirtualHost>

  <Directory /var/www/nextcloud/>
    Options +FollowSymlinks
    AllowOverride All
    <IfModule mod_dav.c>
      Dav off
    </IfModule>
    LimitRequestBody 0
    SSLRenegBufferSize 10486000
  </Directory>
  <IfModule mod_headers.c>
    Header always set Strict-Transport-Security "max-age=15768000; includeSubDo>
  </IfModule>
</IfModule>

And my Cloudflare Tunnel redacted is:

tunnel: $tunnel-ID
credentials-file: /home/$USER/.cloudflared/$tunnel-ID.json

ingress:
  - hostname: sub.domain.com
    service: https://nextcloudpi.local:443
  - service: http_status:404

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.