Warp, Wintun problem - solved

I suddenly started getting problems with the WARP. The connection did not work anymore. Not sure what happened caused this as there was couple of days that I did not use Warp. Could have been some automatic update for example.

On the log it looked like this:

2024-05-26T10:18:35.250Z  INFO wintun: Installing driver 0.14
2024-05-26T10:18:35.250Z  INFO wintun: Extracting driver
2024-05-26T10:18:35.252Z  INFO wintun: Installing driver
2024-05-26T10:18:35.400Z  INFO wintun: Creating adapter
2024-05-26T10:18:50.416Z ERROR wintun: Timed out waiting for device query: The wait operation timed out. (Code 0x00000102)
2024-05-26T10:18:50.417Z ERROR wintun: Failed to setup adapter (problem code: 0x1C, ntstatus: 0xC0000490): There was no match for the specified key in the index. (Code 0x00000491)

Uninstall and reinstall did not help.

Finally found out and tip from Tailscale Github issues, regarding a problem with the Wireguard Wintun drive installation.

Turns out, I had to first uninstall Warp. then remove the driver and then re-install Warp.

  1. Export the list of drivers in the table form to a text file 1using the command:
    dism /online /get-drivers /format:table > c:\drivers.txt

  2. Find wintun or wireguard from the list, and note the “Published Name”, oemNN.inf

  3. Remove the driver using the command:
    pnputil.exe /d oemNN.inf

Source:

1 Like

Thanks for the tip!

First post in a thread can’t be marked as the solution, but I’ll flag this as Solved.

2 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.