WARP VPN Prevents me from playing Team Fortress 2 casual mode

The title is pretty self-explainatory, but I looked a bit more into it and it just can’t connect to the servers
due to a “Local internet problem”.
For now the only fix I found is to remove entirely WARP for the full game and put it back, but the thing is I play TF2 ~2h per day while watching YouTube videos. And knowing what Google cares about privacy…

Things i’ve tried to fix this:

Manually setting the region from the in-game console.
Lowering my firewall.
Changing internet settings.
Resetting the adapter.
Opting out of the Cloudflare WARP Beta program.
Updating Cloudflare WARP to the latest stable version.
Resetting my firewall.

All of these did nothing to fix the issue.
And the issue only appears when using either or WARP. If that can help.

Just two quick notes

  1. WARP “hides” your IP; it’s irrelevant to Google since they can still fingerprint your device and track you normally.
  2. If you have DPI or Layer7 Firewall enabled, that might be the reason why TF2 doesn;t work properly.

Alternatively TF2 might have received a wave of bot/application attacks from WARP users and decided to block the VPN.

One question, if you use as the DNS and WARP is off, does TF2 still not work?

Alr, I re-checked the problem, does not actually trigger.

The issue may be because of the game being full of bots in 2016-mid 2022 and Valve blocked the VPN.
Thank you for answering. I didn’t think about that.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.