WARP-ROUTING Issue

We are getting an error when trying to access private subnets.

ERR cloudflared received a request from WARP client, but your configuration has disabled ingress from WARP clients. To enable this, set “warp-routing:\n\t enabled: true” in your config.yaml

Even though WARP-ROUTER is enabled in config.yaml

tunnel: xxxxxx
credentials-file: /root/.cloudflared/xxxxxxx.json
warp-routing:
enabled: true
no-tls-verify: true

This is causing a HTTP Response Code: 502 on the client side.

Thanks!

Hello,

Does your cloudflared log show this?

INF Warp-routing is enabled

If not, then it means that your configuration is not being picked up. Maybe you are not passing it correctly to cloudflared, or you are passing another config?
Also, the config you showed above does not have the right indentation, maybe that’s the issue. It should be (remember that YAML is indentation sensitive):

warp-routing:
  enabled: true

It doesn’t appear that the log shows WARP-ROUTER is enabled.

I believe the indention is correct. I attached a screenshot.

image

This is the command. I path directly to the config file.

cloudflared tunnel --config root/.cloudflared/config.yaml run test

I appreciate your help!

Definitely seems to be something weird with the config file.

2021-10-14T17:20:19Z INF Cannot determine default configuration path. No file [config.yml config.yaml] in [~/.cloudflared ~/.cloudflare-warp ~/cloudflare-warp /etc/cloudflared /usr/local/etc/cloudflared]
2021-10-14T17:20:19Z INF Version 2021.10.2
2021-10-14T17:20:19Z INF GOOS: linux, GOVersion: devel +a84af465cb Mon Aug 9 10:31:00 2021 -0700, GoArch: amd64
2021-10-14T17:20:19Z INF Settings: map[config:root/.cloudflared/config.yaml]

The strange thing is I can put any tile name here config:root/.cloudflared/config.yaml and it will successfully start the tunnel.

Did you forget a / in the beginning of the path?

cloudflared tunnel --config /root/.cloudflared/config.yaml run test

1 Like

That was it! Not sure how I missed that. I guess I looked past that because the tunnel still started. Thank you!

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.