Warp Routing is not working

I am trying to build a tunnel with Warp using Docker.
I have done all the configurations (domain, private IP, etc.).
My tunnel is working correctly. However, the page is in public.
Why can I see the tunnel with no use WARP app? I can see “Warp-routing is enabled” in the log.
Am I doing something wrong?
I would appreciate your help.

If you want to lock down access to the tunnel and still have a public hostname assigned to it, you need to create an Access policy. Otherwise, you can remove the public hostname and just use the private IP with WARP.

Ohhh… I just understand.
I thought the hostname I added could also be control to access with a warp switch.
It would be easier if I could add my private name too.

Hmm… I wanna connect to localhost of the machine running docker.
If public setting, add a hostname and service “localhost”. What should I do for access localhost in private?