WARP+: Performance regression starting 4/26

As of this morning (April 26), connections through WARP+ on macOS are much slower to non-Cloudflare sites than they were before. For instance, apple.com now takes 650ms+ when connected through WARP+, simply in the “waiting” phase, vs. 45ms when not connected. This seems largely consistent across major sites (Google, Apple, Slack).

Additionally, how would I get support from Cloudflare regarding my routing from AT&T Uverse? I’m not routed to the closest data center, contributing to some of the performance issue right away.

1 Like

Whilst I’ll let someone else comment on the slowness issues since I haven’t used WARP recently, the routing to a Cloudflare colo is dictated largely by your ISP.

Cloudflare’s network operates using any-cast and it’s up to your ISP’s routing & peering agreements as to where you get sent, distance is rarely a high metric - Cloudflare is simply the destination.

You could also check https://www.cloudflarestatus.com/ and see if your nearest colo is in a re-routed status, but if it isn’t, I’d recommend your ISP as the first point of call for routing.

I realize AT&T may be the first point of contact but there doesn’t seem to be a way to report such issues to AT&T and, more importantly, Cloudflare presumably already has much better contacts than I could ever have and already knows how to fix the issue. So is there really no way to report such issues?

I’m facing the same issue on Windows with Warp+. Browsing is slower when I compare it to 1.1.1.1 (no Warp) mode. When I try to access websites, it takes 1-2 seconds for the browser to respond. I’m from Brazil.

I’ve been noticing this slowness for about two days as well.

Warp+

1.1.1.1

Results: WeTransfer - Send Large Files & Share Photos Online - Up to 2GB Free

You can use the bug report feature in the app, I believe it exists on all versions including Desktop

I’ve reported there before, they’ve said routing isn’t an app issue. Does Cloudflare not have a public routing reporting process?

WARP+ has always slowed throughput on those speed tests for me, even when actual browsing latency was unaffected or improved. In general, running with WARP active seems to limit the throughput of a single connection to about half my max, but downloader tools which establish multiple connections can saturate my pipe.

What I’m seeing here is a huge jump in latency across properties like Apple, Google, and Reddit.

My experience with Warp+ has always been quite good. But I don’t know what happened that increased the latency and seems unstable.

There is some flaw that the company has not yet checked. Or, we are the only two affected by the failure.

It seems possible the issue is WARP+'s custom routing, as the increased latency sure feels like an incorrect route to me. Unfortunately there’s no way to turn off the special routing without completely resetting my client, which I don’t really want to do.

I am experiencing the same with iOS and macOS have tried on two different connections from different isps. It’s dropped dramatically with very high latency to most websites.

I don’t think this todo with isp throttling, even my mobile provider is doing the same nubkess 3 different isps here in the UK all decided to throttle at the same time this does look like it’s a warp related issue. Making it unusable at the moment.

I noticed the same. I tried a traceroute from a few non-Cloudflare ISPs back to the external address used as the source of the WARP+ connection, and they are all routing through Australia despite both source and destination in the US. This shows about 300 ms latency. My guess is that non-Cloudflare originated return routes in response are taking this path.

I opened a case via Feedback in the WARP client a couple days ago but have not heard back yet.

Specifically, 104.28.192.0/18 routes appear to be transiting AS1221.

I can also report and confirm massively increased latency for the last few days, in London, GB. While speeds are still regularly great, the latency hit is noticeable.

There’s quite a few folks in the Discord reporting similar issues too, so it seems this is more widespread.

This seems to periodically get worse. I just did a test and it took 20 seconds to start the load of apple.com. Is there any way we can elevate the priority here?

1 Like

It seems like this has been resolved!
Cloudflare Status - Cloudflare Zero Trust: WARP+ performance degradation

This seems improved, as I’m not seeing it 100% of the time now, but I am still seeing it intermittently. At the very least, the deviation seen in my latency tests are still increased when using Warp+. So I don’t think this is completely fixed.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.