Warp on macos not detecting wifi ssid

Hello, I hope I’ve just missed something in the docs or it’s an easy macos permissions update, but…

The “pause warp on wifi networks” doesn’t appear to be working, the switch to disable for all wifi does, but it doesn’t when switching networks. Warp remains on for all wifi networks.

Running macOS Sonoma 14.4 on an M1 MacBook Pro, and the latest non-beta client (Version: 2024.2.68.0). Paying for Warp+ if that’s relevant but the issue existed prior, no zero trust or other enterprise setup.

Digging through the logs, the warp-network.txt file indicates the ssid is null ("ssid": "\u0000").

Anything I can try / thoughts?

Thanks :pray:

I enabled “Disable for all Wi-Fi networks” and tried switching networks. WARP was still disabled for me, however many times I switched network. I am also on WARP Version 2024.2.68.0 (20240214.9), macOS 14.4 23E214 and MacBook Pro with M1 Pro.

Off-topic, for what reason do you have a WARP+ subscription? Genuinely curious. What is your benefit over normal WARP? What is your internet speed? Do you notice a difference?

I also see \u0000 in the logs for SSID. Possibly this is done for privacy of the submitter? SSIDs can be geolocated.

Hmm interesting. Yep, see the same thing on “Disable for all Wi-Fi networks” - that works as expected, it just doesn’t seem to see the SSID when on WiFi.

Mostly to gain the improved routing. I want to be able to leave it turned on most of the time when away from home, and I do a few video calls each day. I haven’t run any comparisons, but I see value in it so I might as well pay for it.

Your comment about the possibility of the SSID being removed from the logs had me curious so i pull the logs from the iPhone to compare. The iPhone logs do include the SSIDs of the various networks I’ve connected to, so I suspect they’re not being redacted for privacy - but that good idea and something i hadn’t checked for. Thanks!

It seems the only file in the macos logs that mentions the SSID I was connected to at the time was dhcp-lease-plists.txt.

I dug into this a little more, and I’m thinking it’s a change introduced in Sonoma.

I tried running the same tests on an old mac I have running Ventura, and the wifi pausing worked perfectly.

Strongly suspect it’s the deprecation of the airport command in Sonoma that’s the root cause of the warp agent not being able to grab the SSID of the current wifi network.

Running airport in Sonoma I get:

/System/Library/PrivateFrameworks/Apple80211.framework/Resources/airport -I
WARNING: The airport command line tool is deprecated and will be removed in a future release.
For diagnosing Wi-Fi related issues, use the Wireless Diagnostics app or wdutil command line tool.

This article seems to be a good write up of the overall issue. Goodbye, airport! - Intuitibits

Sadly this means there’s nothing I can do, and it’ll be down to the Cloudflare WARP devs to update the macos client to use another method to obtain the SSID :cry:

1 Like

This appears to be fixed in the newly released version 2024.3.407.0 :confetti_ball: thanks warp / cloudflare team :pray:

(warp-network.txt is showing the correct SSID now too)