Warp on Linux does not connect

Debian Buster. Need help with diagnosis of the problem.

warp-cli register
warp-cli set-mode warp+doh
warp-cli connect
warp-cli status
Status update: Connecting
curl https://www.cloudflare.com/cdn-cgi/trace/

I’ve tried different modes, warp, warp+doh, proxy, nothing works for me. warp-cli status always replies “Connecting Success”, but when I try to check the connection with curl it always says “warp=off”. My network is IPv4, I’ve tried to enable/disable IPv6 for the ethernet controller in NetworkManager, did not help.

I have the very same issue on Ubuntu 22.04 withthe latest warp-cli.

If I start warp-svc manually (as root) I get some DNS issues

WARN main_loop: warp::warp::connectivity_check: DNS lookup failed error=Custom { kind: Uncategorized, error: "failed to lookup address information: Temporary failure in name resolution" } host="warp-svc."
ERROR main_loop: warp::warp::connectivity_check: DNS connectivity check failed to resolve host="warp-svc."

I don’t know how to debug past that. I have the stub resolver from systems resolv working just fine.

While trying to connect (warp-cli ) I will loose internet connection as well.

Also, when I have cloudflared tunnel running and start warp-svc I see a bunch of errors

Connection terminated error="failed to dial to edge with quic: INTERNAL_ERROR: write udp [::]:56232-> sendto: operation not permitted" connIndex=3

In my case, if I run warp-svc manual, I get errors and warning like this:
ERROR main_loop: warp::warp::happy_eyeballs: Happy eyeballs error Custom { kind: NotConnected, error: "All Happy Eyeballs checks failed" } WARN main_loop: warp::warp: Initial check failed but check_captive_portal reports no problems. Retrying.

Hi guys,
I just faced same trouble on macOS.
Did someone find a solution?