WARP: No connection on macOS

Using CF Warp for access to 2 on-prem IPs. All working perfectly nicely via Windows. Testing on macOS is not going well.

Logging in to CF Zero Trust account is fine, but enabling WARP/Zero Trust won’t connect. Agent says Connecting, then changes to Unable to Connect/Connectivity Check Failed.

There is no Internet connection when WARP agent is turned on. Connection fine when off.

Looking at the Cloudflare dashboard, under My Team > Devices, I noticed the device connection status is ConnectivityCheckFailed(DNSLookupFailed).

My Network DNS is set to auto, but I have also tried changing to No difference at all.

I have turned off the macOS Firewall, and am connected to the same wifi as the Windows machine. I have also tried connecting to a different wifi.

(No difference if I am not logged into CF ZT account).

MacBook Air 2017 Intel CPU
macOS version is 12.4
Client version is 2023.3.460

Split tunneling is set to Include mode and only my 2 local IPs are set.

I have same problem on macOS 13.4.1 with Cloudflare WARP 2023.7.159.0 (20230721.2)
Reinstall macOS doesn’t help, and this problem isn’t fix for few months.