Warp+ License Key links to macOS but does not provide Warp+ connection

As the title suggests.

I am currently using the macOS beta app for Warp. I have an active Warp+ subscription that I purchased on iOS and then used the license key from that to add my macOS app to the account. Both my phone and macOS app are under the same Warp+ account, but right now only my phone is connected to the Warp+ protocol, while my Mac desktop app is only connected to the regular Warp protocol.

Is this a beta issue? I submitted feedback regarding this issue to the beta team anyway, but I do not know if this has to do with the beta app or the actual linking of devices to a Warp+ subscription.

Any help is appreciated.

I have the same setup, but my MacOS Warp+ app is activating with my iOS license key.

What’s showing you that Warp+ isn’t working on your Mac?

When clicking on the Warp icon at the top of the screen, it shows the “Warp+ Unlimited” logo, likely because it registered that my macOS app is using the same license key as my iOS Unlimited subscription. However, in the connection tab under preferences, it says “Connection: Warp”, not “Connection: Warp+”. I’ve also tested this at this link: https://www.udemy.com/cdn-cgi/trace
where at the bottom the value is “warp=on”, not “warp=plus”

Good idea checking udemy. I checked one of my domains and it shows warp+.

So when you check Prefs -> Account, it shows the amount of data remaining, and the devices on the account? And you’ve updated to the latest version?

That’s correct. Here is a screenshot of my Account tab for reference:


Latest version: 1.2.1186

Mine doesn’t say Unlimited, so I don’t know if there are any restrictions on the number of devices. Try opening a Bug Report from the app menu and see what they say.

1 Like

Thanks for the help.

I have already opened a bug report via the in-app reporting system for the beta. There is a maximum to the amount of linked devices which is 5, but currently I only have two linked, so I am well below that number.

1 Like