WARP functions differently on Android compared to Windows?

I have been enjoying WARP on both my Windows and Android devices for more than a year now to access a sports streaming service that is blocked in my country. Everything was working perfectly on both of my devices, but some months ago it suddenly stopped working on my Android even though im still able to access the very same domain on my Windows (which works flawlessly to this day).

On my Android device I had to resort to a different DNS app and configured it to use Cloudflare DNS to get it to work, and it worked nicely for months until a couple of days ago. Now nothing gets the streaming service to work on my Android and I tried many different DNS apps and servers but no luck. I don’t know what is causing the issue here? Same WARP, same settings, same network, pretty much same EVERYTHING except one is a phone and the other is a PC.

What makes the website work on my Windows but not on my Android? What can I do to diagnose the issue? I tried everything I can/know to get this to work again on my Android device but it seems hopeless at this point and I don’t have the technical ability to understand why it refuses to work on Android when the same WARP makes it work flawlessly on Windows. I don’t want to use a VPN because those are costly and slow.

Any insight is greatly appreciated!