WARP for Teams: Registration error. Please try again

Deploying WARP for Teams in an organization. Followed the documentation

  1. configured tenant
  2. created device policy (can use AzureAD login or email to receive auth code)
  3. installed certificate to Trusted Root
  4. installed WARP client

Issue #1 - email with the code never arrived (email is hosted via Microsoft 365) when using email for install.
Issue #2 - When doing AzureAD auth, we login successfully, go to next step and WARP client says Registration error. Please try again.

Tried in several machines - same result.

Here is the odd part - i checked a different tenant we manage for a different organization and it is setup the exact same way. This second tenant works fine and registrations go through.

Some log entries:

[2021-09-20T16:57:33Z ERROR warp::warp_service::api_handlers] API error for request id: Some(48), HttpError(500, Some(WarpApiErrorMessage { code: 2104, message: Some("problem reading response:EOF") }))

[2021-09-20T16:57:33Z DEBUG warp::warp_service::ipc_handlers] Ipc response: 48; Error: Failed to contact the WARP API.

Can you try using all lowercase for the organization/team name (in your MDM config)?

What do you mean in MDM config? I’m installing the client manually. Once we are able to register them successfully, the rest will be installed via script using the switch parameters.

Organization name is entered in lower case in both - in the webUI of the tenant and when trying to register to our Teams account.

Tried disabling IPv6 as suggested in an older thread as a solution, didn’t work.

Anyone? There is no response to this message or the ticket I’ve submitted. So far lack of support doesn’t look promising. We are using the free version as a test with the hope of going with the Enterprise plan for SEIM integration.

Have you had any luck? I have been having the same issue for a week now. Cannot get past linking WARP to teams

No. The strange part is that the same computers and mobile devices register with another Cloudflare account/tenant just fine. It is as if some switch is turned off for this particular Cloudflare account. I’ve opened a ticket with support and sent them logs.

I’ve reset my domain name with the teams, edited and resaved all current settings. I cannot get past this error but states successful in team logs, in the online dashboard, but device doesnt register.

Yes, same here.

Same issue here. Reported the bug in warp client’s feedback. If anyone has a workaround, please share. TYIA!

I’m experiencing the same issue. I cannot add a new device at all and my device policy hasn’t changed. It just says “something went wrong”.

Support representative suggested we try the latest BETA build of the WARP. I tried and that didn’t help. Still looking for a solution.

1 Like

I get the same error when registering wrap on my device. Logs:

2021-10-01T04:13:53Z [INFO][547.TeamsRegistration.startLogIn]Launching URL for teams login: https://<myteam>.cloudflareaccess.com/warp.
2021-10-01T04:13:59Z [INFO][547.AppManager.handleGetURLEvent]Received URL string: eyJhbGciOi. (**)
2021-10-01T04:13:59Z [INFO][547.WarpIPC.createNewTeamsRegistration]Creating new teams registration.
// == Skipped some unrelated logs ==
2021-10-01T04:14:00Z [INFO][547.WarpIPC.createNewTeamsRegistration]Called ipc_new_teams_registration() callback with status: WarpAPI Error
2021-10-01T04:14:00Z [INFO][547.AppManager.createNewRegistration]createNewTeamsRegistration() failed with API error.

What is interesting is the (**) part, the Received URL string eyJhbGciOi looks like the start of a JWT ( {"alg":). I suspect the JWT used for authentication (generated after login) did not pass to WRAP correctly.

PS. Just a random guess, it may be wrong.

Change your Team domain name. I just did it and it started working.
Go to Settings->General->Team domain.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.