Warp for PC not Connecting

Hello Cloudflare Community!

I just have a question about Warp for PC.

I downloaded the Warp for PC and installed it and when I toggle the switch this is what happens:


It switches to the On position but stays Disconnected and doesn’t connect at all.

Back a couple of months ago I had downloaded the Beta version and it was working great, it didn’t have any issues with connecting. The only issue I had with the Beta version it was that when I would click the icon to open it, it would take more than 30 seconds to open and sometimes I had to click the icon several times for it to open.

So, I thought that maybe if I uninstalled the Beta and reinstalled it, that it might fix the issue. (I’m not a computer expert, still learning). I found that when I reinstalled the Beta it started giving me this exact issue where the button will toggle to the “ON” position but still show as “DISCONNECTED”.

Once that happened I tried a few more times over the next few weeks to uninstall and reinstall and it always had the same issue. I decided to wait until the regular app was released for PC, and I reinstalled it and I still have the same issue.

I’m wondering if anyone else has seen this before and if knows if it’s able to be fixed.

Thanks so much!

Hi, I was able to reproduce this issue in Windows by blocking ALL inbound connections.

Untitled DoH works fine with only an outbound connection. with WARP requires an inbound connection, even when it can connect outbound. Having outbound but not inbound connection is what causes this “ON + DISCONNECTED” issue.

During installation the app creates a local inbound windows firewall rule to resolve this issue, but of course the issue is still present when these local rules are ignored, all inbound connections are blocked, or some other app/router firewall is blocking inbound connections.

I cannot know or solve the exact cause of your issue but I hope this is useful.

(I would prefer if WARP could function with only an outbound windows connection but I suppose the implementation would defeat the point of the UDP based protocol? for now I am using a workaround to block all inbound connections/rules except for Cloudflare WARP.)

1 Like

Hi @beary,

Thanks for the response, I really appreciate it!

I think this helps quite a bit.

Thanks again.

This worked for me: go to preferences, connection, “reset all settings” and then reconnect.