WARP Desktop Split Tunnels

Why doesn’t this feature work for me? I added an domain to exclude it from WARP connection in client advanced settings, but when I’m using specified site it’s still going through the WARP. Why is it?
I’m just a home user, not member of a team or something so i don’t have Zero Trust account and plan.