Warp clients unable to communicate

Tried setting up warp to warp connection between 2 machines, can’t get them to connect to eachother. I have everything setup, the excludes, split tunnel, warp to warp enabled…

My linux machine (machine A)

+ ~ ➜ wcl settings
Merged configuration:
(derived)       Always On: true
(network policy)        Switch Locked: false
(network policy)        Mode: WarpWithDnsOverHttps
(Not set)       WARP tunnel protocol: Wireguard
(default)       Disabled for Wifi: false
(default)       Disabled for Ethernet: false
(reg defaults)  Resolve via: 43890exxxxxxd.cloudflare-gateway.com @ [16xxxx1, 260xxxx0::1111]
(Not set)       qlog logging: Disabled
(default)       Onboarding: true
(network policy)        Exclude mode, with hosts/ips:
  10.0.0.0/8
  169.254.0.0/16 (DHCP Unspecified)
  172.16.0.0/12
  192.0.0.0/24
  192.168.0.0/16
  224.0.0.0/24
  240.0.0.0/4
  255.255.255.255/32 (DHCP Broadcast)
  fe80::/10 (IPv6 Link Local)
  fd00::/8
  ff01::/16
  ff02::/16
  ff03::/16
  ff04::/16
  ff05::/16

(network policy)        Fallback domains:
  home.arpa
  intranet
  internal
  private
  localdomain
  domain
  lan
  home
  host
  corp
  local
  localhost
  invalid
  test
(Not set)       Daemon Teams Auth: false
(network policy)        Disable Auto Fallback: false
(network policy)        Captive Portal: 180
(network policy)        Support URL:
(user set)      Organization: nikxxxxxx
(network policy)        Allow Mode Switch: false
(network policy)        Allow Updates: false
(network policy)        Allowed to Leave Org: true
(network policy)        Profile ID: default


+ ~ ➜ curl -v 100.96.0.4:80
*   Trying 100.96.0.4:80...
* connect to 100.96.0.4 port 80 failed: No route to host
* Failed to connect to 100.96.0.4 port 80 after 10023 ms: No route to host
* Closing connection 0
curl: (7) Failed to connect to 100.96.0.4 port 80 after 10023 ms: No route to host

nikola-acer is machine B, a windows machine