WARP Client routing of IPs on local network

Is there a way to force WARP to tunnel and allow traffic destined for remote IPs that overlap with the computer’s current local network?

I have a tunnel configured with a Private IP subnet of 192.168.50.0/24. This range was removed from my split tunnel configuration, so that traffic destined for that network is routed through Cloudflare Gateway. This works fine and allows me to access endpoints on this network, with one exception.

I ran into a situation where my computer was on a different network, which also happened to use the 192.168.50.0/24 network. When I’m on this network, any traffic destined for those addresses gets denied. I get an error stating that network access is denied whenever I try to load anything on an IP on that network.

With more traditional full-tunnel VPNs that I’ve used in the past, the VPN would take precedence over the local network and still tunnel that traffic. But that doesn’t seem to be the case with WARP. It’s seeming like WARP is preferring the local network and not tunneling the traffic, causing the connection to be blocked. Is there a way around this? I’m not seeing any configuration options which would allow me to fix this.

Bumping this topic

You can set different location profiles (a default one when out-of-the office and a custom one for in the office) and configure different split tunnel settings for each under the zero trust WARP client settings. The network is identified by…