Warp client enrolled into Teams but does not seem to be connected to gateway

I use Cloudflare Teams in a test setup.

An iOS client is connected using Warp, logged in to the Teams account. In the Teams dashboard I see the client as “active” and when I go with my client to “xxx.cloudflareaccess.com” (xx being my team name) the debug info also shows the client as connected.

However:

  • when I surf to cloudflare.com/cdn-cgi/trace I see warp=plus but gateway=off
  • when i add access rules requiring he gateway, they don’t work. When I require warp, they do.

EDIT: when I go to help.teams.cloudflare.com under “Team Name” it shows n/a. So it is not detected that Warp on my client is logged in to my team.

So somehow Warp is working, but Cloudflare does not recognise my client as connected to my teams gateway. How can I troubleshoot/fix this?

Additional info: proxy is on, tls decryption is on and the certificate installed and trusted on the client.

I think I have the same problem, any luck with this?

Yes, it works now. The problem is that gateway does not support http/3 yet and as a result the client is not recognised. See discussion here: Cloudflare require gateway is not working - #17 by Sheril_Nagoor

The solution to get this to work on your own Cloudflare domain is to disable http/3 in the settings of the domain (dash.Cloudflare. Com => websites => (your domain) => network => disable http/3.