WARP Client DNS Problem

Hello everyone,
Before connecting to zero trust with WARP client, the DNS of my computer is as follows.

dns

After connecting to zero trust with WARP client, my DNS addresses change. I think this is caused by a setting I made in Zero trust. I didn’t have this problem before. But I can’t find which setting caused this and this is a big problem for me.

dns2

What problem do you encounter? This is how WARP works. Also see this thread.

1 Like

I’ve seen the topic you’re talking about. My problem is that I get a certificate error when accessing some sites that I always connect to. I think this error is caused by this DNS problem. CA certificate is installed on my computer. I want the DNS address not to be changed, can you at least tell me where is the setting for this?

Pretty easy to determine if it is a DNS problem. Do an nslookup on the machine with Warp active and with it disabled. Are the DNS results different? Unlikely they are.

What site?
What error?
Have you checked the Zero Trust logs in the admin console?

Okay, when I have this problem again, I will write here with all the details you asked for.

The only thing I want to know for now is, can you change the DNS that clients will receive from zero trust settings? For example, I want to give google dns to the clients. With which setting can I do this?

As of now, I have experienced the problem, the images are below.


I think it is querying dns queries with ipv6 in zero trust dns locations and that is why I am having problems. However, in WARP split tunnels, only 10.0.0.0/24 range is selected as include. If I find a solution, I will add it here.

As far as I understand, when I select the other 2 options (Gateway with WARP and DOH), except the ones marked in red below, it forces this traffic to go through ipv6 dns, even though I have configured it as ‘Include IPs and domains’ and I specify a single IP blog (x.x.x.x.x/24). The solution for now is to select the options other than these 2 options, i.e. not to include dns in the traffic.