Warp-cli client ubuntu 20.04 dns_proxy error timeout

Hi All,

My clients started using cloudflare, but setting it up in Ubuntu is a bit painful.

Same accounts work great with Windows, but those accounts don’t work in ubuntu.

Ubuntu :- 20.04
warp-cli :- 2024.2.62

Output for /etc/resovl.conf

nameserver 127.0.0.53
options edns0 trust-ad
search .

I’ve tried keeping only name server in the file and various other combination but that doesn’t work.
Network is configured to Automatic DHCP.

Output of sudo lsof -iTCP:53 -iUDP:53 -n -P

systemd-r 421970 systemd-resolve   13u  IPv4 858886      0t0  UDP 127.0.0.53:53 
systemd-r 421970 systemd-resolve   14u  IPv4 858887      0t0  TCP 127.0.0.53:53 (LISTEN)

I’ve tried connecting to plain cloudflare and that works.

BUt when I connect to specifically this team it doesn’t work.

I keep getting “Site is not secure” error for any site I visit.

Admin support for ubuntu is not great on my client side. They only know how to get it configured on windows. So I need a bit of help in setting it up.

Also changing modes gives permission error.

As per logs this seems to be the error. Please let me know if someone could help me on this.

DEBUG dns_proxy::errors: DnsProxy timeout target=4.9.4.6.2.3.3.4.2.7.5.9.e.8.3.d.0.0.0.0.0.0.0.0.0.0.0.0.0.8.e.f.ip6.arpa.

Hi there,

It seems like you’re encountering a DNS resolution issue with the WARP client on Ubuntu. Here’s a step-by-step guide to try and resolve the issue:

  1. Ensure that your warp-cli is up to date, as there have been fixes related to DNS handling in recent versions.
  2. Try disabling the DNS proxy feature by running warp-cli set dns-mode off in the terminal.
  3. If you’re using WARP in conjunction with a local DNS resolver, make sure to configure the local resolver to forward DNS queries to 1.1.1.1 or 1.0.0.1.
  4. Check your firewall settings to ensure that they are not blocking WARP’s DNS queries.
  5. If the issue persists, consider temporarily downgrading to an earlier version of warp-cli that was working for you, until a new update is released that addresses this issue.

If none of these steps work, please make sure you open a ticket with the support team and provide a warp-diag file or error messages for further assistance.

Thanks, Will take a look and get back to you on it.

1 Like

Checked with updated version and that too doesn’t work.

If I config DNS queries to 1.1.1.1 that too does not work.

No firewall enabled.

Will try to submit warp-diag files

Steps 1-5 does not work, will check on how to post the warp-diag files