Warning Uses Deprecated APIs

My blog built in Hugo 0.100.0 with Cloudflare Pages. I got warning on PageSpeed because of Uses deprecated APIs.

I search on their page but I can’t find which part I have to fix or remove. Is there any solution to fix this warning via Cloudflare or another way?

This is my dummy website → https://angora.on.fleek.co (hosted on Fleek) with exactly same code and configuration with my main website → https://angora.id (hosted on Cloudflare)

But the result for my dummy website is better without deprecated warning →

https://pagespeed.web.dev/report?url=https://angora.on.fleek.co

Any idea which part I have to fix?

I suggest you click the :pencil2: next to the Title of your post, so you can re-categorize this for Pages.

Based on Google’s docs, it might be a false positive, as there’s no actual description on what’s Deprecated.

However, as it looks to only happen on Pages, it’s worth taking a closer look at what’s different between Pages, and your Fleek deployment.

1 Like

I’m also seeing this issue on one of my sites using Pages. I think it’s only started in the last couple of weeks.

The site that’s affected for me is: https://www.whychristmas.com/ It’s plain html/css/js, no SSG. None of my other plain html/css sites on Pages are getting the issue.

What’s even stranger is that the pages.dev site: https://whychristmas.pages.dev/ isn’t getting the issue! So they are identical apart from the domain…

So could it be some kind of strange false positive from Google on a Pages forwarder or DNS thing?!

1 Like

Your custom domain has Web Analytics enabled which uses a JS beacon, pages.dev does not.

1 Like

Ok, that’s a start. So why is PageSpeedInsights complaining about it?

I have a site with Cloudflare Insights beacon.min.js, and don’t get that warning. Though I don’t see a beacon on the angora site.

1 Like

Seems to be related to the expect-ct response header added to the responses on the custom domain instead.

image

4 Likes

Oh…that header. I remove it with a Transform rule on all my sites. Strange that it’s called a Deprecated API, though.

Thanks. Recategorized to Cloudflare Pages.

1 Like

I use beacon.min.js on another website and no warning about it. So I think the warning from PageSpeed isn’t about that part.

Solved after remove that part. Thanks.

OK, it’s great to know there’s a solution. Please can someone explain how to set-up the needed Transform Rule?

I’m sure I won’t be the only person who’d like to know how! (I get a bit lost with all the options…)

Thanks for any help :grinning:

I removed deprecated part from headers, not from transform rules.

Ah! I don’t have anything with ‘expect-ct’ in my _headers.

I’ve got

  X-Frame-Options: SAMEORIGIN
  X-Content-Type-Options: nosniff
  Referrer-Policy: no-referrer
  Permissions-Policy: document-domain=()
  Content-Security-Policy: upgrade-insecure-requests;
  Strict-Transport-Security: max-age=31536000; includeSubDomains

Which I don’t think should be doing anything like that?!

Well, I seemed to have solved the issue for my site - but disabling and then re-enabling HSTS under SSL/TLS > Edge Certificates.

I saw some other posts which mentioned expect-ct and HSTS doing odd things, so I wondered if that was involved. I tried disabling HSTS and the error went away. Wanting to test it again, I re-enabled HSTS (turning on the ‘switches’ one at a time) and now all the switches are back on and the error is still gone…

I changed over to using Cloudflare Pages from a Linode/ngix environment a few months ago. Could there have been some sort of odd header cache/clash going on with the switch to CP? I don’t know…

But it seems fixed for me and the site is back on 100 for ‘Best Practices’.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.