Waf not working for English speaking countries

I created five rules blocking access to my website for Australia, Canada, the UK, Ireland, and the USA, which is not working.

I noticed plenty of articles with the same issue. If this feature does not work why do they offer it?

Can you share these rules, so we can look in to them with you?

Did you notice any of the threads claiming the issue could be your use of β€œAND” instead of β€œOR”?

If you create a block rule for:

(ip.geoip.country eq "AU" AND ip.geoip.country eq "CA" AND ip.geoip.country eq "GB" AND ip.geoip.country eq "IE" AND ip.geoip.country eq "US")

A such rule will obviously never work, as β€œAND” here would indicate that country= MUST be all of the country codes, at at the same time.

(ip.geoip.country eq "AU" OR ip.geoip.country eq "CA" OR ip.geoip.country eq "GB" OR ip.geoip.country eq "IE" OR ip.geoip.country eq "US")

Might eventually solve your problem there.

Or, even better, for a block rule, use a list like:

(ip.geoip.country in {β€œAU” β€œCA” β€œGB” β€œIE” β€œUS”})

2 Likes

the rules are easy,
1 Block - block Australia and enable

The same thing with the rest

Can you paste the actual rules like in the last line of the post from @DarkDeviL?

1 Like

Thank you, I figured it out.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.