W3schools.com cannot be resolved in 1.1.1.1 (but resolvable in 1.0.0.1)

I use DoH in Microsoft Edge as says Help Page.
But when I go to w3schools.com Microsoft Edge says “Can’t reach this page” with DNS_PROBE_FINISHED_NXDOMAIN error
Without DoH I get same error message.

Here’s my nslookup output:

C:\Windows\System32>nslookup w3schools.com 1.1.1.1
DNS request timed out.
    timeout was 2 seconds.
Server:  UnKnown
Address:  1.1.1.1

Non-authoritative answer:
Name:    w3schools.com
Address:  66.29.212.110


C:\Windows\System32>nslookup w3schools.com 1.0.0.1
Server:  one.one.one.one
Address:  1.0.0.1

Non-authoritative answer:
Name:    w3schools.com
Address:  66.29.212.110


C:\Windows\System32>nslookup w3schools.com 8.8.8.8
Server:  dns.google
Address:  8.8.8.8

Non-authoritative answer:
Name:    w3schools.com
Address:  66.29.212.110

Every time I run nslookup using 1.1.1.1 there is a timeout.

I can confirm https://www.w3schools.com/ is working for me on 1.1.1.1/1.0.0.1 and 1.1.1.3/1.0.0.3 using FireFox and Chrome (using DoH).

C:\Users\Fritex>nslookup w3schools.com 1.0.0.1
Server:  one.one.one.one
Address:  1.0.0.1

Non-authoritative answer:
Name:    w3schools.com
Address:  66.29.212.110

C:\Users\Fritex>nslookup w3schools.com 1.1.1.1
Server:  one.one.one.one
Address:  1.1.1.1

Non-authoritative answer:
Name:    w3schools.com
Address:  66.29.212.110

Have you tried checking with the steps from below?:

  1. Flush the DNS Cache and Renew Your IP Address ( on Windows OS: ipconfig /flushdns, then ipconfig /release and then ipconfig /renew or via MacOS: dscacheutil -flushcache or on Linux OS: sudo systemd-resolve --flushcaches)
  2. Restart DNS Client Service (net stop dnscache / net start dnscache)
  3. Change DNS Servers to some others (like 8.8.8.8, 8.8.4.4 or 1.1.1.1, 1.0.0.1)
  4. Reset Chrome/Edge Flags ( chrome://flags, edge://flags)
  5. Disable Antivirus Software and Firewalls and VPN Temporarily (if using them)
  6. Check Your Local Hosts File (C:\Windows\System32\Drivers\etc\hosts, /etc/hosts/, /private/etc/hosts)
  7. Check DNS of Your Domain (if this is your domain?)
  8. Clearing Your Web Browser Cache
  9. Restart Your Computer
  10. Restart Your Router

For any lookup, or just for w3schools? There shouldn’t be any difference between 1.0.0.1 and 1.1.1.1

1 Like

Previously it was only on w3schools.com, now there is no timeout. 1.1.1.1 and 1.0.0.1 resolves w3schools.com

The issue was fixed after 3 hours, despite the I did nothing

1 Like

This sounds like potentially a good thing. If I could implement this for members of my team that like to brute force their way through problems too often, landing on terrible w3schools articles, outdated and irrelevant StackOverflow posts, and the odd medium.com blogpost taking them in a completely different direction, then I would happily pay a premium :smile:

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.