Vowifi not working for Reliance Jio

I am not able to use VoWifi whenever I configure cloudflare on my home network for Reliance Jio, seems like a known issue, can you fix please

Where do you see this/where is it known?

I responded in the above thread as well.

“Not working” isn’t much of a description. And, no, I can’t fix it. This is a community forum and I don’t work for Cloudflare. If you need official support, I suggest you contact Support and fully describe the situation.

Do u change dns in reliance JIO router? If yes, right now reliance jio do not support voip services when u change dns in router.

1 Like

I am using a Mikrotik failover router, as soon as I enable OpenDNS or Google DNS, it seems to work fine, the solution to this can be found on the forum where the Jio server needs to be defined from the backend at Cloudflare, not able to reach the support, hope someone can help

Can you clarify this or link to a source? There’s no reason Cloudflare should need to do anything special to facilitate usage with any given ISP; that doesn’t really make sense from a technical standpoint. Something else must be going on.

One example and the solution attached

@mvavrusa Pinging you since it seems like broken Wi-Fi calling nameservers are your specialty.

@anubhav6518, are you able to determine which queries are failing?

@anubhav6518 can you go to https://1.1.1.1/help and post results? If you’re able to capture the domain names that are failing to resolve I can look into these.

2 Likes

I don’t think it’s a browser issue. It’s whatever they’re using to do VoIP. Maybe a phone app. Or just their phone’s Use WiFi for phone calls option.

sdayman, you are absolutely right. Jio give land line(voip) services as well via router. If we change dns in their router those services doesn’t work.

Moreover JIO only has single DNS (no secondary dns) as default. They are improving things daily but it will take some time to resolve these issues.

I understand this, but I am using different ISPs and it works fine on OpenDNS (Authoritative) and Google DNS (Recursive)

I figured the issue here

While using Cloudflare the DNS query is returned from Singapore causing an issue with the Vowifi for Jio

Hope we can resolve

Hi can someone help me with a solution here ?

The exact issue is when you resolve epdg.epc.mnc861.mcc405.pub.3gppnetwork.org using Google DNS or Open DNS, the reply is a local IP -
49.44.59.36, when you use Cloudflare, its gets returned through Singapore with a global IP 49.45.63.2 restricting VoWifi to function. @sdayman @mvavrusa can you please help.

Hm, it seems difficult to obtain the localized IP if the resolver is out of country. I can try and see if we can reroute someplace else.

That will be great, otherwise there is no way the VoWifi can work. Cloudflare does seem to have local cache servers. Hope we can find a solution to this.

Hi, could you find a solution to get this working ?

Hm, it was working for a while, but now it seems to be routed out of country again and I don’t have a good workaround for this situation. There is an ongoing ticket to serve you from a PoP in India instead of Singapore which should resolve this, but it requires capacity expansion so it takes a bit longer. Sorry about that.

Thanks, for your help here. For now, I have applied a workaround, but hoping this issue would get resolved soon for native Vowifi support for Jio.

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.