Visitor ip

Hello, I can’t see the ip addresses of users visiting my website. How can I fix this.

What’s your web server running and do you have full access to make changes to it? Apache? Something else? Have you taken a look here?

Basically you need to look at the “CF-Connecting-IP” header on the incoming requests


I am using “infinityfree[.]net” servers. I don’t have full access. I have file directory and control panel access.

I’m not familiar with them, I assume they have some form of logging but you’re seeing Cloudflare IPs instead of actual visitor IPs? Since they’re a third-party host and you don’t have proper access to reconfigure the web server, you’d be best off contacting them and asking if they can do anything to put the CF-Connecting-IP in the logs.

If they can’t help you out, your only options would be to bypass Cloudflare by grey-clouding your DNS entries, or move hosting so you have more control, or think outside the box a little and put some kind of tracking on your pages. For the last, you could either use some kind of third-party tracking/analytics service, and inject their tracker onto your pages, or you could roll your own by making a grey-clouded subdomain and having all of your pages reference an element on that domain (like an image), such that the logs of that subdomain should grab the real IP of your visitors.

Thank you. I contacted the server team and they have support.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.