Visiting domain returns "Server not found"

I have a CNAME record pointing to google on my website.
However when I try to visit my site it returns “Server not found”.

I have contacted support.

Do you mean you tried to do something like this?

First of all, why?

Second, that’s unlikely to work… the way CNAMEs work with HTTP is that the browser/client looks up the IP address of the CNAME target, but then when they make the connection, they set the “Host:” header equal to the original name, not the CNAME target. If HTTPS, the original name will also be used in the TLS handshake.

So basically the browser will try to connect to a Google server, and say to it “I want to see something.example.com”. But the Google server will have no idea what to do with that request.

What exactly are you trying to do? Are you trying to actually send visitors to Google when they hit your subdomain? If so you need to use a redirect, which you can accomplish in multiple says such as (but not limited to) Page Rules or Bulk Redirects

2 Likes

I was trying to set a CNAME to google as a test because I had a site being hosted and all of the sudden Cloudflare stopped redirecting clients to my site.

I’m still not clear exactly what you’re trying to do but if you want to redirect traffic to Google you can do it via a page rule like this

This will cause all traffic to https://something.example.com/ to be redirected to the Google front page, without preserving the rest of the URL path. https://google.com/$1 if you want to preserve the path for some reason.

DNS entry must be orange-clouded for page rules to work.

I’m trying to get my Cloudflare domain to point to my site but no matter what I do it always returns the “Server not found”

Well that’s a different question then

post the domain name & a screenshot of your DNS page, also it would be helpful if you would grey-cloud your DNS entries temporarily to simplify troubleshooting

1 Like

My domain name is osvnrocks(dot)uk

osvnrocks.uk is not even showing as a registered domain. Cloudflare Registrar shows it as available for purchase. Did you just try to purchase the domain today? Through Cloudflare Registrar or somewhere else? Either way you should double-check to see if the purchase actually went through. Or is it possibly a domain you used to own but it expired?

I contacted them and they said I paid for the domain. It says the domain is active aswell. I bought the domain July 13th of this year.

Everything I’m seeing indicates that it’s unregistered.

Did you purchase it through Cloudflare Registrar? Or somebody else? If Cloudflare Registrar, can you screenshot your “Manage Domains” page?


I did purchase from the Cloudflare registrar

Something’s definitely not right with the domain registration, very weird

Every registrar I’ve checked (including Cloudflare) shows it as available for purchase

Did you check your bank to see if you were actually charged for the domain purchase? Was there any kind of subsequent refund?

.UK is kinda weird because you also have Nominet in the mix. Are you able to log in to Log In - Nominet UK ? If you’ve never logged into it before you’ll have to use the “forgot password” link

But it seems kinda like Cloudflare never relayed the domain purchase to Nominet

Also try [email protected] and be very specific about the issue (domain you purchased shows as unregistered in whois database)

It went through.
I will try the methods you explained.

Support was no help

Please check the audit log on the dashboard. Search by the domain name and look for July 15, @user4358 is spot-on, appears registration did not go through.

I noticed that the team is working with you on a couple of tickets, that slows down the reply time for you and everyone else. I merged them into 2511835, the team will communicate with you on that ticket. I’ll make a note of that for my #reliability:registrar and #general:billing colleagues.


wrt the original issue, a the value of a CNAME record needs to resolve in order to work, test-c1n.pages.dev does not

2 Likes

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.